Closed Bug 678124 Opened 9 years ago Closed 9 years ago

GIFs don't animate, pages don't load, unless I move the mouse

Categories

(Firefox :: General, defect)

5 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 627084

People

(Reporter: edwardsgreg, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330

Steps to reproduce:

On the very odd occasion, Firefox will end up in a broken state. In this state, most types of dynamic events, will stop completely unless I move the mouse around. Unfortunately, I haven't been able to track down the cause. It seems random. I'm visiting sites I normally visit and experience no problems with.


Actual results:

Symptoms include:
GIFs stop animating.
The cursor stops blinking.
setTimeout events don't happen.
Pages won't load. (!)
Mouse wheeling behaves abnormally and sometimes scrolls in the wrong direction.
Menus don't open.

All of these symptoms go away if I keep moving the mouse around, click the mouse, scroll the wheel (but see above), or type. Moving or resizing the window doesn't bring Firefox back to life. Moving the mouse in the non-client area of the window causes things to resume. Moving the mouse around outside the window doesn't.


Expected results:

None of these bizarre side-effects.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 627084
You need to log in before you can comment on or make changes to this bug.