Last Comment Bug 678155 - Remove NS_COM completely.
: Remove NS_COM completely.
Status: RESOLVED FIXED
[inbound]
:
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla9
Assigned To: Matheus Kerschbaum
:
: Nathan Froyd [:froydnj]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-11 03:08 PDT by Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
Modified: 2011-08-19 03:08 PDT (History)
3 users (show)
matjk7: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (181.65 KB, patch)
2011-08-11 17:51 PDT, Matheus Kerschbaum
benjamin: review+
Ms2ger: checkin+
Details | Diff | Splinter Review

Description Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-08-11 03:08:26 PDT
Since libxul became mandatory NS_COM has been #defined away.  We should remove the NS_COM annotations from our code.
Comment 1 Matheus Kerschbaum 2011-08-11 17:51:48 PDT
Created attachment 552559 [details] [diff] [review]
patch
Comment 3 Marco Bonardo [::mak] 2011-08-19 03:08:44 PDT
http://hg.mozilla.org/mozilla-central/rev/e8cb0687737a

Note You need to log in before you can comment on or make changes to this bug.