Last Comment Bug 678201 - [jsdbg2] Use CallArgs throughout Debugger.cpp
: [jsdbg2] Use CallArgs throughout Debugger.cpp
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Other Branch
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Jason Orendorff [:jorendorff]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-11 08:23 PDT by Jason Orendorff [:jorendorff]
Modified: 2011-08-11 15:32 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
part 1 - preliminary - v1 (10.11 KB, patch)
2011-08-11 11:30 PDT, Jason Orendorff [:jorendorff]
luke: review+
Details | Diff | Splinter Review
part 2 - move - v1 (3.48 KB, patch)
2011-08-11 11:30 PDT, Jason Orendorff [:jorendorff]
luke: review+
Details | Diff | Splinter Review
part 3 - Debugger - v1 (13.97 KB, patch)
2011-08-11 11:31 PDT, Jason Orendorff [:jorendorff]
luke: review+
Details | Diff | Splinter Review
part 4 - Script - v1 (10.90 KB, patch)
2011-08-11 11:31 PDT, Jason Orendorff [:jorendorff]
luke: review+
Details | Diff | Splinter Review
part 5 - Frame - v1 (13.79 KB, patch)
2011-08-11 11:32 PDT, Jason Orendorff [:jorendorff]
luke: review+
Details | Diff | Splinter Review
part 6 - Object - v1 (17.08 KB, patch)
2011-08-11 13:29 PDT, Jason Orendorff [:jorendorff]
luke: review+
Details | Diff | Splinter Review

Description Jason Orendorff [:jorendorff] 2011-08-11 08:23:43 PDT
Per bug 672829 comment 69.
Comment 1 Jason Orendorff [:jorendorff] 2011-08-11 11:30:16 PDT
Created attachment 552442 [details] [diff] [review]
part 1 - preliminary - v1

The CheckThis code is fake generality. It turns out only one class uses it. So I go ahead and specialize it.
Comment 2 Jason Orendorff [:jorendorff] 2011-08-11 11:30:59 PDT
Created attachment 552444 [details] [diff] [review]
part 2 - move - v1

Move the newly specialized code just before its first use.
Comment 3 Jason Orendorff [:jorendorff] 2011-08-11 11:31:25 PDT
Created attachment 552446 [details] [diff] [review]
part 3 - Debugger - v1
Comment 4 Jason Orendorff [:jorendorff] 2011-08-11 11:31:52 PDT
Created attachment 552447 [details] [diff] [review]
part 4 - Script - v1
Comment 5 Jason Orendorff [:jorendorff] 2011-08-11 11:32:18 PDT
Created attachment 552449 [details] [diff] [review]
part 5 - Frame - v1
Comment 6 Jason Orendorff [:jorendorff] 2011-08-11 13:29:59 PDT
Created attachment 552487 [details] [diff] [review]
part 6 - Object - v1

That's it, 6 patches. It looks nicer this way.
Comment 7 Luke Wagner [:luke] 2011-08-11 14:23:43 PDT
Comment on attachment 552444 [details] [diff] [review]
part 2 - move - v1

Review of attachment 552444 [details] [diff] [review]:
-----------------------------------------------------------------

I admire your patch-fu.  I should emulate this.
Comment 8 Luke Wagner [:luke] 2011-08-11 14:28:35 PDT
Comment on attachment 552446 [details] [diff] [review]
part 3 - Debugger - v1

Review of attachment 552446 [details] [diff] [review]:
-----------------------------------------------------------------

So far we have been writing "CallArgs args = ...".  This is two chars more, but, as a nice side effect, "args[0]" reads nicely.  Grepping, there also seems to be "CallArgs call = ..." in a few places... I should fix this; it would be nice to have a canonical name.  r+ with s/ca/args/, or we can continue discussion.
Comment 9 Jason Orendorff [:jorendorff] 2011-08-11 15:32:55 PDT
http://hg.mozilla.org/users/jblandy_mozilla.com/jsdbg2/rev/eec543e3c644

Note You need to log in before you can comment on or make changes to this bug.