Open Bug 67837 Opened 19 years ago Updated 7 years ago

"Empty Trash" should be "Empty Trash on <account>

Categories

(SeaMonkey :: MailNews: General, enhancement)

enhancement
Not set

Tracking

(Not tracked)

People

(Reporter: sspitzer, Unassigned)

Details

Attachments

(1 obsolete file)

we did this in 4x.

"File | Empty Trash", should be "File | Empty Trash on <account>"
adding 4xp keyword.
Keywords: 4xp
QA Contact: esther → sheelar
Summary: "Empty Trash" should be "Empty Trash on <account>" → Empty Trash" should be "Empty Trash on <account>
Keywords: mozilla1.0
Rather, I think it should be something like the following which also would take
care of bug #112944:
File
  Empty Trash
    (account name 1)
    (account name 2)
     ---------------
     Empty All Trash

I am also changing the mozilla1.0 keyword to mozilla 1.2 since 1.0 is already out.
Keywords: mozilla1.0mozilla1.2
QA Contact: sheelar → esther
Actually, in the main file menu empty trash should just
empty the trash on all the accounts.  If the user wants
to empty trash on just one account they can right click
on that account and empty the trash.

Suggestion:  rename the menu item to "Empty Trash on All Accounts"
Severity: normal → trivial
Summary: Empty Trash" should be "Empty Trash on <account> → "Empty Trash" should be "Empty Trash on <account>
Assuming that the behavior of the "Empty Trash" File menu item IS in fact to
empty trash for all accounts, here is a patch to do what the last comment
suggested... if not, please disregard this.
Comment on attachment 149011 [details] [diff] [review]
Patch to implement suggestions in comment #3

Going ahead and setting this for review.
Attachment #149011 - Flags: review?(sspitzer)
Testing with Mozilla Mail reveals that that ISN'T the current behavior...
withdrawing review. I'll look into the "Empty Trash on <account>" behavior though.
Attachment #149011 - Attachment is obsolete: true
Attachment #149011 - Flags: review?(sspitzer)
Product: Browser → Seamonkey
Assignee: sspitzer → mail
Assignee: mail → nobody
QA Contact: esther → message-display
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → EXPIRED
Still a valid RFE.
Severity: trivial → normal
Status: RESOLVED → REOPENED
Component: MailNews: Message Display → MailNews: General
Ever confirmed: true
QA Contact: message-display → mail
Hardware: x86 → All
Resolution: EXPIRED → ---
Status: REOPENED → NEW
Severity: normal → enhancement
You need to log in before you can comment on or make changes to this bug.