Last Comment Bug 678686 - package-manifest should has $(GLOBAL_DEPS) dependency
: package-manifest should has $(GLOBAL_DEPS) dependency
Status: RESOLVED FIXED
[inbound]
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla9
Assigned To: Makoto Kato [:m_kato]
:
Mentors:
Depends on:
Blocks: 671567
  Show dependency treegraph
 
Reported: 2011-08-12 20:03 PDT by Makoto Kato [:m_kato]
Modified: 2011-08-21 17:49 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (566 bytes, patch)
2011-08-12 20:15 PDT, Makoto Kato [:m_kato]
bugspam.Callek: review+
Details | Diff | Splinter Review
for comm-central (2.26 KB, patch)
2011-08-17 18:09 PDT, Makoto Kato [:m_kato]
bugspam.Callek: review+
Details | Diff | Splinter Review

Description Makoto Kato [:m_kato] 2011-08-12 20:03:55 PDT
Although I have added ANGLE support for Win64, ANGLE files isn't included in Win64 installer.  Because package-manifest isn't updated even if autoconf.mk is changed.

We should add $(GLOBAL_DEPS) dependency to package-manifest/package-manifest.in.
Comment 1 Makoto Kato [:m_kato] 2011-08-12 20:15:59 PDT
Created attachment 552825 [details] [diff] [review]
fix
Comment 2 Justin Wood (:Callek) 2011-08-13 06:55:21 PDT
Comment on attachment 552825 [details] [diff] [review]
fix

I'm not technically a reviewer, but this is obvious enough for me to happily attach my name to it.

Alternatively you can use "FORCE" as a dep here, like mobile does.

either way, I think http://mxr.mozilla.org/mozilla-central/source/mobile/installer/Makefile.in#99 should match while you're doing this. (but I won't dare review the potential dropping of the FORCE dep there)

ALSO would appreciate (but not required for this bug) to patch the three places in comm-central (you can take an rs+=me for those changes if you do them)

http://mxr.mozilla.org/comm-central/source/mail/installer/Makefile.in#95
http://mxr.mozilla.org/comm-central/source/suite/installer/Makefile.in#129
http://mxr.mozilla.org/comm-central/source/calendar/installer/Makefile.in#90
Comment 3 Makoto Kato [:m_kato] 2011-08-17 18:09:42 PDT
Created attachment 553971 [details] [diff] [review]
for comm-central
Comment 4 Makoto Kato [:m_kato] 2011-08-17 19:48:18 PDT
landed to inbound
http://hg.mozilla.org/integration/mozilla-inbound/rev/1b6414e98c4e
Comment 5 Marco Bonardo [::mak] (Away 6-20 Aug) 2011-08-18 03:59:44 PDT
http://hg.mozilla.org/mozilla-central/rev/1b6414e98c4e
Comment 6 Makoto Kato [:m_kato] 2011-08-21 17:49:11 PDT
landed to c-c
http://hg.mozilla.org/comm-central/rev/9ae88a03c47d

Note You need to log in before you can comment on or make changes to this bug.