Last Comment Bug 678763 - Intermittent browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
: Intermittent browser_sourceeditor_initialization.js | application timed out a...
Status: RESOLVED FIXED
[test which aborts the suite][test di...
: intermittent-failure
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: Trunk
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Mihai Sucan [:msucan]
:
: J. Ryan Stinnett [:jryans] (use ni?)
Mentors:
Depends on:
Blocks: 438871
  Show dependency treegraph
 
Reported: 2011-08-13 14:31 PDT by Mihai Sucan [:msucan]
Modified: 2012-11-25 19:31 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
[in-fx-team] proposed fix (2.29 KB, patch)
2011-08-15 08:43 PDT, Mihai Sucan [:msucan]
rcampbell: review+
Details | Diff | Splinter Review
[in-fx-team] another fix (3.15 KB, patch)
2011-08-17 05:38 PDT, Mihai Sucan [:msucan]
rcampbell: review+
Details | Diff | Splinter Review

Description Mihai Sucan [:msucan] 2011-08-13 14:31:06 PDT
Test runs fine but the application crashes.

s: talos-r3-fed-018
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)


I never saw this crasher and I have no clue why it might happen.
Comment 1 Treeherder Robot 2011-08-14 04:25:50 PDT
khuey
http://tinderbox.mozilla.org/showlog.cgi?log=Try/1313296449.1313297725.2893.gz
Rev3 Fedora 12x64 try opt test mochitest-other on 2011/08/13 21:34:09

s: talos-r3-fed64-016
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 2 Phil Ringnalda (:philor) 2011-08-14 14:30:21 PDT
That's an intentional crash following the previous line, which is the significant part: "application timed out after 330 seconds with no output." The test hangs, so we crash in the (usually vain) hope that the stack from the crash will tell you what was hung.
Comment 3 Treeherder Robot 2011-08-14 14:30:40 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1313355498.1313356883.18589.gz
Rev3 Fedora 12 mozilla-inbound opt test mochitest-other on 2011/08/14 13:58:18

s: talos-r3-fed-028
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 4 Treeherder Robot 2011-08-14 18:10:00 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1313368200.1313369510.20443.gz
Rev3 Fedora 12x64 mozilla-inbound opt test mochitest-other on 2011/08/14 17:30:00

s: talos-r3-fed64-028
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 5 Treeherder Robot 2011-08-14 21:08:33 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1313378469.1313379866.14134.gz
Rev3 Fedora 12 mozilla-inbound opt test mochitest-other on 2011/08/14 20:21:09

s: talos-r3-fed-055
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 6 Treeherder Robot 2011-08-14 21:08:43 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1313379539.1313380843.16301.gz
Rev3 Fedora 12 mozilla-inbound opt test mochitest-other on 2011/08/14 20:38:59

s: talos-r3-fed-019
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 7 Treeherder Robot 2011-08-14 22:53:19 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1313385360.1313386650.31045.gz
Rev3 Fedora 12x64 mozilla-inbound opt test mochitest-other on 2011/08/14 22:16:00

s: talos-r3-fed64-003
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 8 Treeherder Robot 2011-08-15 00:56:57 PDT
Ms2ger%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Try/1313357218.1313358528.22503.gz
Rev3 Fedora 12 try opt test mochitest-other on 2011/08/14 14:26:58

s: talos-r3-fed-055
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 9 Treeherder Robot 2011-08-15 04:45:57 PDT
Ms2ger%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1313406117.1313407825.30001.gz
Rev3 Fedora 12x64 mozilla-central opt test mochitest-other on 2011/08/15 04:01:57

s: talos-r3-fed64-052
10797 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/layout/generic/test/test_bug632379.xul | Test timed out.
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 10 Treeherder Robot 2011-08-15 07:15:31 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1313409836.1313411126.10851.gz
Rev3 Fedora 12 mozilla-inbound opt test mochitest-other on 2011/08/15 05:03:56

s: talos-r3-fed-044
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 11 Mihai Sucan [:msucan] 2011-08-15 08:43:03 PDT
Created attachment 553183 [details] [diff] [review]
[in-fx-team] proposed fix

Proposed fix. Just open a tab and remove it, as in a usual mochitest. I believe the failure might be caused by a test harness bug.
Comment 12 Rob Campbell [:rc] (:robcee) 2011-08-15 08:54:41 PDT
Comment on attachment 553183 [details] [diff] [review]
[in-fx-team] proposed fix

let's try it!
Comment 13 Mihai Sucan [:msucan] 2011-08-15 09:12:00 PDT
Comment on attachment 553183 [details] [diff] [review]
[in-fx-team] proposed fix

Landed:

http://hg.mozilla.org/integration/fx-team/rev/36dc4ffaaaae

Let's hope this fixes the intermittent failures. Rob, thanks for the r+!
Comment 14 Treeherder Robot 2011-08-15 09:22:07 PDT
ttaubert
http://tinderbox.mozilla.org/showlog.cgi?log=Fx-Team/1313421592.1313422856.28265.gz
Rev3 Fedora 12x64 fx-team opt test mochitest-other on 2011/08/15 08:19:52

s: talos-r3-fed64-059
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 15 Treeherder Robot 2011-08-15 10:04:31 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Build-System/1313419320.1313420622.19479.gz
Rev3 Fedora 12x64 build-system opt test mochitest-other on 2011/08/15 07:42:00

s: talos-r3-fed64-046
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 16 Treeherder Robot 2011-08-15 13:49:23 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Fx-Team/1313430899.1313432272.29052.gz
Rev3 Fedora 12x64 fx-team opt test mochitest-other on 2011/08/15 10:54:59

s: talos-r3-fed64-013
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 17 Phil Ringnalda (:philor) 2011-08-15 13:50:06 PDT
And that last one is from the push after your fix landed, so I'm afraid that wasn't it.
Comment 18 Treeherder Robot 2011-08-15 13:52:17 PDT
mbrubeck%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1313432865.1313434285.3554.gz
Rev3 Fedora 12x64 mozilla-central opt test mochitest-other on 2011/08/15 11:27:45

s: talos-r3-fed64-025
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 19 Treeherder Robot 2011-08-15 13:53:50 PDT
ttaubert
http://tinderbox.mozilla.org/showlog.cgi?log=Fx-Team/1313431804.1313433097.31883.gz
Rev3 Fedora 12 fx-team opt test mochitest-other on 2011/08/15 11:10:04

s: talos-r3-fed-046
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 20 Treeherder Robot 2011-08-15 13:54:13 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1313432865.1313434285.3554.gz
Rev3 Fedora 12x64 mozilla-central opt test mochitest-other on 2011/08/15 11:27:45

s: talos-r3-fed64-025
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 21 Treeherder Robot 2011-08-15 13:55:01 PDT
ttaubert
http://tinderbox.mozilla.org/showlog.cgi?log=Fx-Team/1313431804.1313433097.31883.gz
Rev3 Fedora 12 fx-team opt test mochitest-other on 2011/08/15 11:10:04

s: talos-r3-fed-046
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 22 Treeherder Robot 2011-08-15 14:20:28 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1313434303.1313435764.10536.gz
Rev3 Fedora 12 mozilla-inbound opt test mochitest-other on 2011/08/15 11:51:43

s: talos-r3-fed-035
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 23 Mihai Sucan [:msucan] 2011-08-15 14:25:53 PDT
I suggest disabling the test and go for try server runs, and see why it fails.

Will look into this more, tomorrow.
Comment 24 Treeherder Robot 2011-08-15 15:50:35 PDT
ehsan
http://tbpl.mozilla.org/php/getParsedLog.php?id=5976113
Rev3 Fedora 12 mozilla-central opt test mochitest-other on 2011-08-15 14:06:27

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 25 Treeherder Robot 2011-08-15 16:28:15 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1313439079.1313440436.27758.gz
Rev3 Fedora 12 mozilla-inbound opt test mochitest-other on 2011/08/15 13:11:19

s: talos-r3-fed-042
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 26 Treeherder Robot 2011-08-15 17:01:46 PDT
zpao
http://tinderbox.mozilla.org/showlog.cgi?log=Fx-Team/1313434813.1313436097.11888.gz
Rev3 Fedora 12 fx-team opt test mochitest-other on 2011/08/15 12:00:13

s: talos-r3-fed-034
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 27 Treeherder Robot 2011-08-15 17:46:18 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1313441393.1313442923.5638.gz
Rev3 Fedora 12x64 mozilla-inbound opt test mochitest-other on 2011/08/15 13:49:53

s: talos-r3-fed64-044
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 28 Treeherder Robot 2011-08-15 18:42:15 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Jaegermonkey/1313436151.1313437478.16709.gz
Rev3 Fedora 12 jaegermonkey opt test mochitest-other on 2011/08/15 12:22:31

s: talos-r3-fed-006
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 29 Treeherder Robot 2011-08-15 19:05:55 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1313444286.1313445835.17475.gz
Rev3 Fedora 12 mozilla-inbound opt test mochitest-other on 2011/08/15 14:38:06

s: talos-r3-fed-029
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 30 Treeherder Robot 2011-08-15 19:41:20 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1313442277.1313443550.8430.gz
Rev3 Fedora 12x64 mozilla-central opt test mochitest-other on 2011/08/15 14:04:37

s: talos-r3-fed64-030
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 31 Treeherder Robot 2011-08-15 19:41:34 PDT
dholbert%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1313442277.1313443550.8430.gz
Rev3 Fedora 12x64 mozilla-central opt test mochitest-other on 2011/08/15 14:04:37

s: talos-r3-fed64-030
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 32 Treeherder Robot 2011-08-15 21:13:05 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1313449320.1313450950.5199.gz
Rev3 Fedora 12 mozilla-inbound opt test mochitest-other on 2011/08/15 16:02:00

s: talos-r3-fed-048
10798 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/layout/generic/test/test_bug632379.xul | Test timed out.
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_bug597248.js | Test timed out
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 33 Treeherder Robot 2011-08-15 23:47:19 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1313455949.1313457518.29947.gz
Rev3 Fedora 12 mozilla-central opt test mochitest-other on 2011/08/15 17:52:29

s: talos-r3-fed-039
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 34 Treeherder Robot 2011-08-16 00:23:44 PDT
Ms2ger%gmail.com
http://tbpl.mozilla.org/php/getParsedLog.php?id=5983089
Rev3 Fedora 12 mozilla-central opt test mochitest-other on 2011-08-15 21:52:55

10801 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/layout/generic/test/test_bug632379.xul | Test timed out.
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 35 Treeherder Robot 2011-08-16 02:00:03 PDT
ttaubert
http://tinderbox.mozilla.org/showlog.cgi?log=Fx-Team/1313442123.1313443818.9586.gz
Rev3 Fedora 12 fx-team opt test mochitest-other on 2011/08/15 14:02:03

s: talos-r3-fed-050
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_bug597248.js | Test timed out
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 36 Treeherder Robot 2011-08-16 02:02:22 PDT
Ms2ger%gmail.com
http://tbpl.mozilla.org/php/getParsedLog.php?id=5985005
Rev3 Fedora 12 mozilla-inbound opt test mochitest-other on 2011-08-15 23:23:39

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 37 Treeherder Robot 2011-08-16 03:43:10 PDT
Ms2ger%gmail.com
http://tbpl.mozilla.org/php/getParsedLog.php?id=5985731
Rev3 Fedora 12 mozilla-inbound opt test mochitest-other on 2011-08-16 01:52:09

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
buildbot.slave.commands.TimeoutError: command timed out: 1200 seconds without output, attempting to kill
Comment 38 Treeherder Robot 2011-08-16 03:49:30 PDT
Ms2ger%gmail.com
http://tbpl.mozilla.org/php/getParsedLog.php?id=5985733
Rev3 Fedora 12 mozilla-inbound opt test mochitest-other on 2011-08-16 02:04:05

10850 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/layout/generic/test/test_bug632379.xul | Test timed out.
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 39 Treeherder Robot 2011-08-16 06:13:51 PDT
Ms2ger%gmail.com
http://tbpl.mozilla.org/php/getParsedLog.php?id=5986829
Rev3 Fedora 12 mozilla-central opt test mochitest-other on 2011-08-16 04:13:47

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 40 Treeherder Robot 2011-08-16 07:08:51 PDT
ehsan
http://tbpl.mozilla.org/php/getParsedLog.php?id=5986287
Rev3 Fedora 12 mozilla-inbound opt test mochitest-other on 2011-08-16 01:24:43

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
buildbot.slave.commands.TimeoutError: command timed out: 1200 seconds without output, attempting to kill
Comment 41 Treeherder Robot 2011-08-16 07:10:37 PDT
ehsan
http://tbpl.mozilla.org/php/getParsedLog.php?id=5988675
Rev3 Fedora 12 mozilla-central opt test mochitest-other on 2011-08-16 06:03:30

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 42 Treeherder Robot 2011-08-16 07:11:53 PDT
ehsan
http://tbpl.mozilla.org/php/getParsedLog.php?id=5988576
Rev3 Fedora 12x64 mozilla-central opt test mochitest-other on 2011-08-16 06:02:35

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 43 Treeherder Robot 2011-08-16 07:30:28 PDT
ehsan
http://tbpl.mozilla.org/php/getParsedLog.php?id=5989342
Rev3 Fedora 12 mozilla-central opt test mochitest-other on 2011-08-16 06:54:02

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 44 Treeherder Robot 2011-08-16 07:34:17 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1313458232.1313459558.4884.gz
Rev3 Fedora 12 mozilla-inbound opt test mochitest-other on 2011/08/15 18:30:32

s: talos-r3-fed-058
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 45 Treeherder Robot 2011-08-16 07:34:45 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1313457302.1313458579.1619.gz
Rev3 Fedora 12x64 mozilla-inbound opt test mochitest-other on 2011/08/15 18:15:02

s: talos-r3-fed64-055
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 46 :Ehsan Akhgari 2011-08-16 07:57:30 PDT
I disabled the test because it was practically perma-orange!
Comment 47 Treeherder Robot 2011-08-16 08:26:13 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1313480355.1313484846.24088.gz
Rev3 Fedora 12 mozilla-inbound opt test mochitest-other on 2011/08/16 00:39:15

s: talos-r3-fed-020
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
buildbot.slave.commands.TimeoutError: command timed out: 1200 seconds without output, attempting to kill
Comment 48 Treeherder Robot 2011-08-16 08:26:43 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1313480598.1313484754.23760.gz
Rev3 Fedora 12 mozilla-inbound opt test mochitest-other on 2011/08/16 00:43:18

s: talos-r3-fed-022
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
buildbot.slave.commands.TimeoutError: command timed out: 1200 seconds without output, attempting to kill
Comment 49 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-08-16 10:05:29 PDT
(In reply to Mihai Sucan [:msucan] from comment #11)
> Proposed fix. Just open a tab and remove it, as in a usual mochitest. I
> believe the failure might be caused by a test harness bug.

I don't see how this could have made a difference - a new tab in the opening window shouldn't affect anything. Isn't it more likely that your window load listener is running before the opened window's load listener, or something like that?
Comment 50 Mihai Sucan [:msucan] 2011-08-16 10:18:58 PDT
(In reply to Gavin Sharp from comment #49)
> (In reply to Mihai Sucan [:msucan] from comment #11)
> > Proposed fix. Just open a tab and remove it, as in a usual mochitest. I
> > believe the failure might be caused by a test harness bug.
> 
> I don't see how this could have made a difference - a new tab in the opening
> window shouldn't affect anything. Isn't it more likely that your window load
> listener is running before the opened window's load listener, or something
> like that?

Not really, because the test runs fine. I believe it was a matter of focus. That assumption still holds true - I mean I still believe it's a problem of focus.

I talked to Tim Taubert on #fxteam and also believes the same. Between tests the test harness waits for focus on the main browser window and here the main browser window is never focused once the test ends (once the SourceEditor window is closed). This happens because (1) the SE window closes and the window manager picks the "running test" window instead of focusing the main browser window, and (2) my attempt to focus the main window fails because all code runs too fast.

Locally I was able to reproduce the problem under "special circumstances". The solution:
http://tbpl.mozilla.org/?tree=Try&rev=fb0045334099

... still waiting for results. What it does: it waits for the SE window to get focus, then run tests, then close, and properly focus the main window. This works locally.

Thoughts?
Comment 51 Mihai Sucan [:msucan] 2011-08-16 10:54:03 PDT
Results are green:

http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/mihai.sucan@gmail.com-fb0045334099

... manually checked the logs, because the TBPL page is now broken - I don't know why.

(still, on Mac *many*/almost all devtools tests failed due to bug 679301)
Comment 52 Treeherder Robot 2011-08-16 11:15:33 PDT
philor
http://tbpl.mozilla.org/php/getParsedLog.php?id=5989337
Rev3 Fedora 12 mozilla-inbound opt test mochitest-other on 2011-08-16 06:51:16

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 53 Treeherder Robot 2011-08-16 11:33:13 PDT
philor
http://tbpl.mozilla.org/php/getParsedLog.php?id=5992353
Rev3 Fedora 12 mozilla-inbound opt test mochitest-other on 2011-08-16 10:52:21

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 54 Treeherder Robot 2011-08-16 22:06:04 PDT
philor
http://tbpl.mozilla.org/php/getParsedLog.php?id=5997386
Rev3 Fedora 12x64 mozilla-inbound opt test mochitest-other on 2011-08-16 21:01:13

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 55 Treeherder Robot 2011-08-16 22:11:07 PDT
philor
http://tbpl.mozilla.org/php/getParsedLog.php?id=5983521
Rev3 Fedora 12x64 jaegermonkey opt test mochitest-other on 2011-08-15 22:37:59

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 56 Treeherder Robot 2011-08-16 23:26:46 PDT
philor
http://tbpl.mozilla.org/php/getParsedLog.php?id=5997835
Rev3 Fedora 12 mozilla-inbound opt test mochitest-other on 2011-08-16 22:20:09

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 57 Treeherder Robot 2011-08-17 00:24:29 PDT
philor
http://tbpl.mozilla.org/php/getParsedLog.php?id=5998186
Rev3 Fedora 12 mozilla-inbound opt test mochitest-other on 2011-08-16 23:35:00

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 58 Treeherder Robot 2011-08-17 00:55:29 PDT
ttaubert
http://tinderbox.mozilla.org/showlog.cgi?log=Fx-Team/1313502249.1313503614.30588.gz
Rev3 Fedora 12x64 fx-team opt test mochitest-other on 2011/08/16 06:44:09

s: talos-r3-fed64-025
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 59 Treeherder Robot 2011-08-17 03:11:31 PDT
mounir
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1313558409.1313559749.29695.gz
Rev3 Fedora 12 mozilla-inbound opt test mochitest-other on 2011/08/16 22:20:09

s: talos-r3-fed-041
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 60 Mihai Sucan [:msucan] 2011-08-17 05:38:35 PDT
Created attachment 553737 [details] [diff] [review]
[in-fx-team] another fix

Another attempt to fix the intermittent failures. This patch now enables the test.

This had green try results. http://tbpl.mozilla.org/?tree=Try&rev=fb0045334099
Comment 61 Rob Campbell [:rc] (:robcee) 2011-08-17 05:46:39 PDT
Comment on attachment 553737 [details] [diff] [review]
[in-fx-team] another fix

I don't really have a great sense that this is going to fix the problem. It feels like we're starting to get into circular patch cycles to try to make this work without really fixing the problem.

I'd like to understand what's actually causing this failure, but can give this patch a try. If it doesn't work, we'll need to try something more radical.
Comment 62 Treeherder Robot 2011-08-17 06:05:37 PDT
mak77%bonardo.net
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1313584449.1313585776.10085.gz
Rev3 Fedora 12 mozilla-inbound opt test mochitest-other on 2011/08/17 05:34:09

s: talos-r3-fed-024
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application timed out after 330 seconds with no output
PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/sourceeditor/test/browser_sourceeditor_initialization.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 63 Mihai Sucan [:msucan] 2011-08-17 08:38:04 PDT
(In reply to Rob Campbell [:rc] (robcee) from comment #61)
> Comment on attachment 553737 [details] [diff] [review]
> another fix
> 
> I don't really have a great sense that this is going to fix the problem. It
> feels like we're starting to get into circular patch cycles to try to make
> this work without really fixing the problem.
> 
> I'd like to understand what's actually causing this failure, but can give
> this patch a try. If it doesn't work, we'll need to try something more
> radical.

Please see comment 50 for details.
Comment 64 Mihai Sucan [:msucan] 2011-08-17 09:24:17 PDT
Comment on attachment 553737 [details] [diff] [review]
[in-fx-team] another fix

Thanks for the r+!

Patch landed:
http://hg.mozilla.org/integration/fx-team/rev/75eeb6cb7050

If this still fails, then (1) Try server is not reliable :( and (2) we really need a more radical approach, as pointed out.
Comment 65 :Ehsan Akhgari 2011-08-17 10:17:13 PDT
(In reply to comment #64)
> If this still fails, then (1) Try server is not reliable :(

When writing a fix for an intermittent variable, it's often a good idea to run the affected test suite on your try server job multiple times (you can do that from TBPL.)  For example, if you're dealing with a test which fails 3 out of 5 times, running the Moth tests 20 times can give you a pretty good idea on whether the problem has been really fixed, or whether you're just being lucky on the first run.
Comment 66 Rob Campbell [:rc] (:robcee) 2011-08-18 12:37:44 PDT
Comment on attachment 553737 [details] [diff] [review]
[in-fx-team] another fix

http://hg.mozilla.org/mozilla-central/rev/75eeb6cb7050

Note You need to log in before you can comment on or make changes to this bug.