ICS calendar fails when connection temporarily unavailable

RESOLVED FIXED in 1.0

Status

defect
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: mmecca, Assigned: mmecca)

Tracking

unspecified
x86
All
Dependency tree / graph

Details

Attachments

(1 attachment, 1 obsolete attachment)

Assignee

Description

8 years ago
Reloading a remote ics calendar with the connection unavailable will sometimes fail with 

Error: [Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIHttpChannel.responseStatus]"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: file:///media/Data/mozilla/obj-i686-pc-linux-gnu-comm-miramar/mozilla/dist/xpi-stage/lightning/components/calICSCalendar.js :: <TOP_LEVEL> :: line 920"  data: no]
Source File: file:///media/Data/mozilla/obj-i686-pc-linux-gnu-comm-miramar/mozilla/dist/xpi-stage/lightning/components/calICSCalendar.js
Line: 920

This can leave the calendar in a locked state, and prevent further operations even if the connection becomes available again.
Assignee

Updated

8 years ago
Assignee: nobody → matthew.mecca
Status: NEW → ASSIGNED
Assignee

Comment 1

8 years ago
Posted patch Fix v1 (obsolete) — Splinter Review
Allow provider to fail gracefully when encountering potentially temporary connection issues on load
Attachment #553095 - Flags: review?(philipp)
Assignee

Updated

8 years ago
Blocks: 529771
Duplicate of this bug: 678966
Comment on attachment 553095 [details] [diff] [review]
Fix v1

Review of attachment 553095 [details] [diff] [review]:
-----------------------------------------------------------------

r=philipp with the following nits. Feel free to push to all three branches.

::: calendar/providers/ics/calICSCalendar.js
@@ +944,5 @@
>          // 404: Not Found
>          // This is a new calendar. Shouldn't try to parse it. But it also
>          // isn't a failure, so don't throw.
> +        if (responseStatus == 404) {
> +            cal.LOG("[calICSCalendar] 404: Not Found.");

I'd suggest being more verbose on the log message here since a file not found isn't really a bad thing for new calendars.
Attachment #553095 - Flags: review?(philipp) → review+
Assignee

Comment 4

8 years ago
Posted patch Fix v2Splinter Review
De-bitrotted, more verbose messages.
Attachment #553095 - Attachment is obsolete: true
Attachment #562347 - Flags: review+
Assignee

Comment 6

8 years ago
I'll push to comm-beta after the merge.
Assignee

Comment 7

8 years ago
Pushing to comm-aurora per Bug 543323 comment #12
Assignee

Updated

8 years ago
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0b8
You need to log in before you can comment on or make changes to this bug.