Assertion failure: rt->onOwnerThread()

RESOLVED DUPLICATE of bug 704249

Status

()

Core
Plug-ins
--
critical
RESOLVED DUPLICATE of bug 704249
7 years ago
6 years ago

People

(Reporter: bc, Unassigned)

Tracking

(Blocks: 1 bug, {assertion})

Trunk
x86
Linux
assertion
Points:
---

Firefox Tracking Flags

(firefox8 affected)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 553176 [details]
crash report

1. http://www.gothic.org.au/main/showthread.php?1922-Can-you-be-friends-with-someone-your-in-love-with
2. Assertion failure: rt->onOwnerThread(), at /work/mozilla/builds/nightly/mozilla/js/src/jsapi.cpp:6199

Nightly/8 Linux x86/x86_64 only so far.

Comment 1

7 years ago
The stack makes this look like it's actually a plugin problem to me.
Assignee: general → nobody
Component: JavaScript Engine → Plug-ins
QA Contact: general → plugins
(Reporter)

Comment 2

7 years ago
It may be another of the java/icedtea off thread issues.

Comment 3

7 years ago
The release-mode assert was added by bug 650411 recently as the JS engine is moving to be single-threaded.

Comment 4

7 years ago
While the assert was backed out, its going to come back once bug 675221 lands.  Is there anything we need to do to reach out to the plugin authors?

Comment 5

6 years ago
Hi there,

I stumbled upon this issue after a recent SM + Java update.

Browser: Mozilla/5.0 (X11; Linux x86_64; rv:10.0.1) Gecko/20120217 Firefox/10.0.1 SeaMonkey/2.7.1
Java: Java-Version:1.6.0_24 
OpenJDK Runtime Environment (IcedTea6 1.11.1) (Gentoo build 1.6.0_24-b24)
OpenJDK 64-Bit Server VM (build 20.0-b12, mixed mode)
URL: <http://speed.sunrise.ch/speedtest/#>

[at page loading]
---------------------------------------------------------------------
$ HSI Performance Applet                                                                                                     
Version: 3.7.0
cnlab AG (http://www.cnlab.ch/)
Exception in thread "AWT-EventQueue-4" java.lang.NullPointerException
        at ch.cnlab.performanceapplet.b.i.b(Unknown Source)
        at ch.cnlab.performanceapplet.b.j.actionPerformed(Unknown Source)
        at javax.swing.Timer.fireActionPerformed(Timer.java:313)
        at javax.swing.Timer$DoPostEvent.run(Timer.java:244)
        at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:226)
        at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:647)
        at java.awt.EventQueue.access$000(EventQueue.java:96)
        at java.awt.EventQueue$1.run(EventQueue.java:608)
        at java.awt.EventQueue$1.run(EventQueue.java:606)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:105)
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:617)
        at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
        at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
        at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
        at java.awt.EventDispatchThread.run(EventDispatchThread.java:138)

[at applet start]
---------------------------------------------------------------------
Assertion failure: rt->onOwnerThread(), at /var/tmp/portage/www-client/seamonkey-2.7.1/work/comm-release/mozilla/js/src/jsapi.cpp:6316


Same problem with FF-10.0.1 (though no exception is thrown at page loading)

Assertion failure: rt->onOwnerThread(), at /builds/slave/rel-m-rel-lnx64-bld/build/js/src/jsapi.cpp:6316


Cheers,

  ^m'e

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 704249
You need to log in before you can comment on or make changes to this bug.