When saving files, file widget should be initialized with page title

VERIFIED WONTFIX

Status

VERIFIED WONTFIX
18 years ago
2 years ago

People

(Reporter: sfraser_bugs, Assigned: law)

Tracking

({regression})

Trunk
mozilla1.1alpha
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
When doing a Save As in the brower (from menu or context menu), the file picker 
shows up with the word 'untitled' as the default file name (on Mac at least). It 
should be initialized with the file name. The same is also true of various save 
file dialogs in mailnews.
(Reporter)

Comment 1

18 years ago
Typo above. It should be initialized with the file *title*, cleaned up in such a 
way that it is a valid platform filename, and with the appropriate file extension 
added.
this is very similar to bug 31519, except that one doesn't suggest using the
page title [which is what 4.x does].
Keywords: 4xp

Comment 3

18 years ago
(Ccing mpt, setting OS to All.  Leaving severity as normal for now because I'm 
not sure whether Mozilla has a problem on Mac that it doesn't have on Windows.)

Current behavior on Win98: most webpages initially have the filename in the 
Save As dialog when saving from Mozilla, but directory index files such as 
http://www.mozila.org/ or http://mozilla.org/credits/ have an empty filename 
(bug 24817).  Is the current behavior on Mac different?

I agree with the reporter that it would be good to try to use the page title as 
the default filename.  My reasoning is that it's usually more difficult to 
copy/type a page title manually than it is to copy/type a filename, and because 
most users are more interested in the page title than its filename on the 
server.

If the page doesn't have a title or has a title with no "good" characters, 
Mozilla should fall back to the last part of the url.  For example, 
http://www.mozilla.org/credits/ would become credits.html if it didn't have a 
title, and http://www.mozilla.org/ would become www_mozilla_org.html.  A title-
less page from http://www.mozilla.org/query.cgi?... would become query_cgi.html 
(bug 31519).

In some cases, titles set by the browser should be ignored.  For example, we 
wouldn't want to save http://www.mozilla.org/images/mozilla-banner.gif 
as "Image_600x58 pixels".  On the other hand, finger:justin@nullsoft.com should 
be saved as "justin@nullsoft_com.txt" or "Finger information for 
justin@nullsoft_com.txt".

For URLs like "data:text/html,asdf" that don't give titles, Mozilla will have 
to use "untitled.html" or leave the field blank.

I'm not sure what characters should be escaped (especially, whether periods 
should be escaped).
OS: Mac System 8.5 → All

Comment 4

18 years ago
Yeah, what Jesse said. Minor point: The suggested filename should never be 
nothing.

Updated

18 years ago
Keywords: mozilla1.0
(Assignee)

Comment 5

17 years ago
Setting target milestone.
Target Milestone: --- → mozilla1.1
spam: over to File Handling.
Component: XP Apps: GUI Features → File Handling

Comment 7

17 years ago
There seem to be some "dueling bugs" going on with regard to what default
filename to use... bug 115176 seems to be the exact inverse of this one,
objecting to the use of title text or link text as a default filename instead of
the actual filename shown in the URL.  The actual behavior seems to have varied
greatly between different Mozilla builds, and also has varied by whether you're
using the 
Save As feature in the File menu, or a right-click context menu for saving the
contents of a link, or a normal click on a link that produces data of a MIME
type that is saved rather than displayed.

I think there needs to be a preference setting for this, or else there will
always be warring camps between people who prefer use of the "true filename" and
those who prefer the page title (or link text if saved by right click).

Perhaps a new bug needs to be opened to discuss the general issue of how to
handle default filenames on save, as there are several different sub-issues
involved here.  As it now stands, the bugs I know of deal only with specific
narrow cases, and are all written from the standpoint of favoring one or another
position on them.  A "big-picture" bug would be more useful toward trying to
resolve the whole matter in a way that everybody can live with.
Fixed by "save as complete page" landing.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
right. rs vrfy. other issues covered by separate/newer bugs.
Status: RESOLVED → VERIFIED

Comment 10

17 years ago
To reproduce:
1.  While viewing this bug report, choose `File' > `Save Page As...'
2.  Look at the default name for the file.

What you should see:
*   `Bug 67901 - When saving files,'

What you actually see:
*   `show_bug.cgi.html'

Problem occurs in:
*   build 2002040508, Mac OS 9.2

Does not occur in:
*   Netscape Communicator 4.79
*   iCab 2.6
*   Microsoft Internet Explorer 5.1

Reopening.
Status: VERIFIED → REOPENED
Keywords: regression
Resolution: FIXED → ---

Comment 11

17 years ago
Not this again. You want title to be the default filename for all saves? 

Comment 12

17 years ago
I'd rather keep it at the filename than the page title... page titles usually
have spaces, punctuation, and other stuff I'd rather not use in filenames, and
if I'm saving stuff from a Web site in its original structure I'd like to keep
the names the way they are in the remote site.  Granted, this will sometimes
produce silly names (like when the pages are CGI-generated and they all have
"show_bug.cgi" as the filename), but in most normal cases I'd like to use the
filename, not the title.
mpt, see bug 115176.  This bug's fix was backed out for cases when the url has a
filename in it, per discussion (flaming, whatever) in that bug.

Comment 14

17 years ago
This bug was fixed with a checkin, verified, then the checkin was backed out.
Then the bug was reopened, but we're not re-addressing the issue. Resolving as
fixed to restore the previous state of the bug.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED
re-zap.
Status: RESOLVED → VERIFIED

Comment 16

16 years ago
I have found MS-IE's behavior (of using page titles as the default filenames 
and embedding the page URLs in the saved files as a comment line) to be rather 
useful -- I often use it instead of bookmarking pages now, if the page is 
important (bookmarks don't work if the webpage disappears).  The original page 
filename is quite useless when saving pages, from say, eBay...

I *NEED* to have the page saving feature behave like it does in MS-IE.  
Because of this (and ONLY because of this), I am *FORCED* to continue using MS-
IE.  Can't you folks make any sort of option to toggle this?  Even just a line 
in prefs.js !!!

Thanks in advance...

Alex
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Please file an RFE to that effect.  Reopening old bugs with lots of confused
comments is _not_ the way to get that to happen.

Marking wontfix, since that's what we really did with this bug.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → WONTFIX
v
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.