Closed Bug 679088 Opened 10 years ago Closed 10 years ago

Line numbers don't line up to lines in orion

Categories

(DevTools :: General, defect, P1)

x86
macOS
defect

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 10

People

(Reporter: mossop, Unassigned)

References

Details

(Whiteboard: [sourceeditor][orion])

Attachments

(1 file)

Attached image screenshot
The line numbers don't line up to the source code, it is a little confusing.
This is fine with default settings, but I have my monospace font set to Monaco which is what causes the problem
Hearing that this also happens with Inconsolata, and likely others.

see http://grab.by/aP5t

I noticed that the orion.css uses a font size of pts instead of px though probably not the cause of this. In any case, some investigation is warranted.
platform should be all, I encounter same issue in both Win xp sp3 and Win 7sp1.
Whiteboard: [sourceeditor][orion]
On Linux I can reproduce the bug with Monaco, but not with Inconsolata. (latest Orion upstream code)
We're doing developer tool prioritization, filter on 'brontozaur'
to ignore the spam.
Priority: -- → P1
Bug reported upstream:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=362286

Also submitted a proposed fix for review.
Depends on: 697407
This is now fixed by bug 697407. QA will verify.

The proposed fix is still pending review upstream.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 10
Verified on Build identifier: Mozilla/5.0 (X11; Linux i686; rv:10.0a1) Gecko/20111107 Firefox/10.0a1 with various fonts set for monospace font
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.