Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Line numbers don't line up to lines in orion

RESOLVED FIXED in Firefox 10

Status

()

Firefox
Developer Tools
P1
normal
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: mossop, Unassigned)

Tracking

Trunk
Firefox 10
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [sourceeditor][orion])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 553243 [details]
screenshot

The line numbers don't line up to the source code, it is a little confusing.
(Reporter)

Comment 1

6 years ago
This is fine with default settings, but I have my monospace font set to Monaco which is what causes the problem
Hearing that this also happens with Inconsolata, and likely others.

see http://grab.by/aP5t

I noticed that the orion.css uses a font size of pts instead of px though probably not the cause of this. In any case, some investigation is warranted.

Comment 3

6 years ago
platform should be all, I encounter same issue in both Win xp sp3 and Win 7sp1.

Updated

6 years ago
Whiteboard: [sourceeditor][orion]
On Linux I can reproduce the bug with Monaco, but not with Inconsolata. (latest Orion upstream code)

Comment 5

6 years ago
We're doing developer tool prioritization, filter on 'brontozaur'
to ignore the spam.
Priority: -- → P1
Bug reported upstream:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=362286

Also submitted a proposed fix for review.

Updated

6 years ago
Depends on: 697407
This is now fixed by bug 697407. QA will verify.

The proposed fix is still pending review upstream.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

6 years ago
Target Milestone: --- → Firefox 10
Verified on Build identifier: Mozilla/5.0 (X11; Linux i686; rv:10.0a1) Gecko/20111107 Firefox/10.0a1 with various fonts set for monospace font
You need to log in before you can comment on or make changes to this bug.