Last Comment Bug 679226 - Fold widget/src/ into widget/
: Fold widget/src/ into widget/
Status: RESOLVED FIXED
[not-fennec-11]
:
Product: Core
Classification: Components
Component: Widget (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla12
Assigned To: Brian R. Bondy [:bbondy]
:
:
Mentors:
Depends on:
Blocks: 627956
  Show dependency treegraph
 
Reported: 2011-08-15 17:11 PDT by Brian R. Bondy [:bbondy]
Modified: 2012-02-06 16:15 PST (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Folded. Patch v1. (173.98 KB, patch)
2011-12-30 12:37 PST, Brian R. Bondy [:bbondy]
no flags Details | Diff | Splinter Review
Folded. Patch v2. (189.18 KB, patch)
2012-01-02 12:27 PST, Brian R. Bondy [:bbondy]
roc: review+
Details | Diff | Splinter Review

Description Brian R. Bondy [:bbondy] 2011-08-15 17:11:35 PDT
The contents of widget/src into  belong in widget.
Comment 1 Brian R. Bondy [:bbondy] 2011-08-15 17:12:12 PDT
The above line should read: 
The contents of widget/src belong in widget/
Comment 2 Zack Weinberg (:zwol) 2011-08-15 17:39:18 PDT
Should we also move the contents of widget/public up one? If so, it would make sense to do it in this bug.
Comment 3 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-08-15 18:58:40 PDT
Yeah
Comment 4 Brian R. Bondy [:bbondy] 2011-12-30 12:37:32 PST
Created attachment 585025 [details] [diff] [review]
Folded.  Patch v1.

Running through try before requesting review.  

Changes:
- Folded widget/src into widget
- Adjusted relative paths in Makefile.in files
- Did a :%s/widget\/src/widget\//g in the rest of the files
- Did a build locally and it worked (windows)
- Running through try for other platforms now
Comment 5 :Ms2ger (⌚ UTC+1/+2) 2011-12-31 03:10:36 PST
Comment on attachment 585025 [details] [diff] [review]
Folded.  Patch v1.

>--- a/accessible/accessible-docs.html
>+++ b/accessible/accessible-docs.html
> our case, this event is received in <a
>- href="http://lxr.mozilla.org/seamonkey/source/widget/src/windows/nsWindow.cpp#4370">mozilla/widget/src/windows/nsWindow.cpp</a>.
>+ href="http://lxr.mozilla.org/seamonkey/source/widget/windows/nsWindow.cpp#4370">mozilla/widget/windows/nsWindow.cpp</a>.

Want to make this point to m-c? The seamonkey tree is apparently used only by bugzilla.

>--- a/widget/src/windows/tests/Makefile.in
>+++ b/widget/windows/tests/Makefile.in
>+# XXX None of these stuff works in libxul builds.

I say it's time to remove it, then!
Comment 6 :Ms2ger (⌚ UTC+1/+2) 2011-12-31 03:12:58 PST
Also, widget/public?
Comment 7 Zack Weinberg (:zwol) 2011-12-31 03:22:58 PST
It looks like some files in widget/(src/)windows/tests/ got their line ending convention changed; I don't know if that's desirable.

Please also move the contents of widget/public up one, per comments 2 and 3.  It would probably be clearest to do this in a second patch (also in this bug, however).
Comment 8 Brian R. Bondy [:bbondy] 2011-12-31 12:30:46 PST
> It looks like some files in widget/(src/)windows/tests/ got their line ending 
> convention changed; I don't know if that's desirable.

That was on purpose since those files end with windows line endings currently (CRLF) and it should be unix line endings (LF).


> Please also move the contents of widget/public up one, per comments 2 and 3.
> It would probably be clearest to do this in a second patch
> (also in this bug, however).

Will do regarding the widget/public.
Comment 9 Brian R. Bondy [:bbondy] 2012-01-02 12:12:11 PST
I'll leave the following to another bug by the way, please post a new bug with specifics.

> > --- a/widget/src/windows/tests/Makefile.in
> > +++ b/widget/windows/tests/Makefile.in
> > +# XXX None of these stuff works in libxul builds.

> I say it's time to remove it, then!
Comment 10 Brian R. Bondy [:bbondy] 2012-01-02 12:27:26 PST
Created attachment 585322 [details] [diff] [review]
Folded. Patch v2.

- Now also folded /widget/public into /widget
- Fixed URL to point to mozilla-central instead.

The last try result succeeded by the way but I'm re-pushing to try with the new changes before requesting review.
Comment 11 Brian R. Bondy [:bbondy] 2012-01-03 12:00:47 PST
try run looks good:
https://tbpl.mozilla.org/?tree=Try&rev=c56aeade4b48
Comment 12 Brian R. Bondy [:bbondy] 2012-01-03 19:15:28 PST
Pushed to mozilla-inbound:
http://hg.mozilla.org/integration/mozilla-inbound/rev/e57e271bf328
Comment 13 Marco Bonardo [::mak] 2012-01-04 04:56:25 PST
https://hg.mozilla.org/mozilla-central/rev/e57e271bf328

Note You need to log in before you can comment on or make changes to this bug.