Intermittent a11y/accessible/events/test_tree.xul | Test timed out, sometimes with a leak

RESOLVED FIXED in mozilla10

Status

()

Core
Disability Access APIs
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: philor, Assigned: surkov)

Tracking

(Blocks: 1 bug, {intermittent-failure})

Trunk
mozilla10
x86_64
Linux
intermittent-failure
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1313451229.1313454933.20357.gz
Rev3 Fedora 12x64 mozilla-inbound debug test mochitest-other on 2011/08/15 16:33:49
s: talos-r3-fed64-026

2995 INFO TEST-PASS | chrome://mochitests/content/a11y/accessible/events/test_tree.xul | test with ID = 'insertRow: TreeRowCountChanged' failed. No TreeRowCountChanged event.
2996 INFO TEST-PASS | chrome://mochitests/content/a11y/accessible/events/test_tree.xul | test with ID = 'TreeInvalidated on insertRow' failed. No TreeInvalidated event.
--DOMWINDOW == 61 (0x35007b8) [serial = 115] [outer = 0x2cbf820] [url = about:blank]
--DOMWINDOW == 60 (0x2b85a98) [serial = 114] [outer = 0x2cbf820] [url = about:blank]
--DOMWINDOW == 59 (0x2cbf898) [serial = 113] [outer = (nil)] [url = about:blank]
2997 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/a11y/accessible/events/test_tree.xul | Test timed out.

Updated

6 years ago
Blocks: 518190
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Updated

6 years ago
Summary: Intermittent a11y/accessible/events/test_tree.xul | Test timed out. → Intermittent a11y/accessible/events/test_tree.xul | Test timed out, sometimes with a leak
(Assignee)

Comment 48

6 years ago
enable logging for the test on inbound https://hg.mozilla.org/integration/mozilla-inbound/rev/d5954910540e

please don't mark as fixed
https://hg.mozilla.org/mozilla-central/rev/d5954910540e
I had to backout the logging you pushed in comment 48 since it caused mochitest-other on Windows and Linux debug to permanetly leak... I wonder if you should take a deeper look at what a11y logging does if it causes perma leaks.
(Assignee)

Comment 51

6 years ago
I have logs and will look closer, thank you for backing out it.
(Assignee)

Comment 52

6 years ago
Created attachment 564874 [details] [diff] [review]
enable logging
Attachment #564874 - Flags: review?(marco.zehe)

Updated

6 years ago
Attachment #564874 - Flags: review?(marco.zehe) → review+
(Assignee)

Comment 53

6 years ago
enable loggin inbound land https://hg.mozilla.org/integration/mozilla-inbound/rev/2db0dafb8f30
Comment hidden (Treeherder Robot)
(In reply to alexander surkov from comment #53)
> enable loggin inbound land
> https://hg.mozilla.org/integration/mozilla-inbound/rev/2db0dafb8f30

https://hg.mozilla.org/mozilla-central/rev/2db0dafb8f30

Leaving open since logging only.
Assignee: nobody → surkov.alexander
Status: NEW → ASSIGNED
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 64

6 years ago
Created attachment 566126 [details] [diff] [review]
patch

a log:

Event queue:
  invoke: invalidate row
registered: event type: name changed, target: no target description
registered: event type: name changed, target: no target description
registered: event type: TreeInvalidated, target: no target description

Event type: name changed. Target: ['tree@id="tree" node', address: 0x8605008, role: gridcell, name: 'row1_col1', address: 0x7b6d290]. Listeners count: 1
EQ matched: name changed

4285 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/a11y/accessible/events/test_tree.xul | Test timed out.

insertRow test: change from "row0_col0"/"row1_col1" to "aloha 1x0"/"aloha 1x1"

name changed is fired for old value. I see that mouse move over the tree restores all previous values in the tree what means data.colsText didn't keep new values in  reachable way. It appears this bug is caused by this behavior.
Attachment #566126 - Flags: review?(marco.zehe)
Comment hidden (Treeherder Robot)
Comment on attachment 566126 [details] [diff] [review]
patch

r=me. Curious that this is a matter of parameters that this fails intermittently. Thanks for finding it!
Attachment #566126 - Flags: review?(marco.zehe) → review+
(Assignee)

Comment 67

6 years ago
inbound land https://hg.mozilla.org/integration/mozilla-inbound/rev/6bfe61a76eb0
https://hg.mozilla.org/mozilla-central/rev/6bfe61a76eb0
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla10
Alex, do you want to disable logging again for this now that the actual fix landed?
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Keywords: intermittent-failure
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.