problem with editing the text after copying by mouse in 5.0.1/6.0.2/7.0.1

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
7 years ago
5 years ago

People

(Reporter: Sergey Y. Afonin, Unassigned)

Tracking

7 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:2.0.1) Gecko/20110328 Firefox/4.0.1
Build ID: 20110502184744

Steps to reproduce:

Hello.

I found problem in Firefox 5.0.1 (ALT Linux binary) on http://translate.google.ru

1. go to http://translate.google.ru
2. select translation from Russian to English, for example
3. put a phrase in left box
4. select (by mouse) phrase in right box
5. copy it by middle click to left box
6. to attempt to edit




Actual results:

copied text is not editable


Expected results:

copied text should be edited
Mozilla/5.0 (X11; Linux i686; rv:9.0a1) Gecko/20110818 Firefox/9.0a1
Mozilla/5.0 (X11; Linux i686; rv:5.0.1) Gecko/20100101 Firefox/5.0.1

Please correct me if I am wrong about the STR's. I was not very sure about step 5 and 6 there.

1. Go to http://translate.google.ru
2. Select any two languages to be translated
3. Type/copy wome words in the left box.
4. Select (by mouse) the phrase in the right column (theresult).
5. Copy it by dragging with left click to the box in the left.
6. Attempt to edit.

Does the issue still occur if you start Firefox in Safe Mode?
http://support.mozilla.com/en-US/kb/Safe+Mode

How about with a new, empty profile?
http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile
Mozilla/5.0 (X11; Linux i686; rv:9.0a1) Gecko/20110818 Firefox/9.0a1
Mozilla/5.0 (X11; Linux i686; rv:5.0.1) Gecko/20100101 Firefox/5.0.1

Using the above STR's everything worked for me.
(Reporter)

Comment 3

7 years ago
It is happens in safe mode also. But I found the cause of accident: firefox 5.0 started to copy the text with all the html-attributes. I can even copy the input box to input box now (see attachment). And I'm not sure now that this bug firefox. Is it a new feature, which is not expected by Google ?
(Reporter)

Comment 4

7 years ago
Created attachment 554626 [details]
Input Box in Input Box
Have you tried with the clean profile? Maybe it's related to some changes you made to your user profile.

Does this occur since upgrading to Firefox 6?

I don't think that is intended.
(Reporter)

Comment 6

7 years ago
I tested it with new profile in 6.0.2. Bug persists.
Summary: problem with editing the text after copying by mouse in 5.0.1 → problem with editing the text after copying by mouse in 5.0.1/6.0.2
(Reporter)

Comment 7

7 years ago
it remains unchanged in
Mozilla/5.0 (X11; Linux i686; rv:7.0.1) Gecko/20110328 Firefox/7.0.1
Summary: problem with editing the text after copying by mouse in 5.0.1/6.0.2 → problem with editing the text after copying by mouse in 5.0.1/6.0.2/7.0.1
Version: 5 Branch → 7 Branch
(Reporter)

Comment 8

5 years ago
I tested in with 17.0.9. It works now.
But I don't know who fixed it. You or Google...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.