{css1} www.image.dk menu does not render properly. small redraw error

VERIFIED DUPLICATE of bug 6630

Status

()

Core
Layout
P3
normal
VERIFIED DUPLICATE of bug 6630
19 years ago
11 years ago

People

(Reporter: Henrik Lynggaard Hansen, Assigned: buster)

Tracking

({css1})

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
the menu on www.image.dk, has a small redraw problem in the top left corner

system is win95 running nightly build from 17/05-1999
(Reporter)

Comment 1

19 years ago
Created attachment 230 [details]
Screen dump showing the error

Comment 2

19 years ago
The small top left part is a frame of itself. It contains nothing but a
background-picture (A) and a "corner"-picture (B). It has no text in it. The
"Forsiden"-gif (C) is located in a frame of itself. In no way should part of the
"Forsiden"-gif be shown in the small upper left frame.

It seems like that the upper left frame shows B, and for some reason C
(underneath, the button to the left of "Forsiden" is part of the gif.

My best guess should be that C is used as a background-picture, instead of A,
for some reasons.

- Peter Brodersen (pb@wol.dk),
webmaster at www.image.dk

Updated

19 years ago
Assignee: rickg → kmcclusk

Comment 3

19 years ago
A rendering bug for you.
Looks like a frameset rendering problem. As the window is made smaller a small
rectangle of the banner at the top of the page is duplicated in the upper-left
corner and moves along toward the left as the window is made smaller.

Updated

19 years ago
Assignee: kmcclusk → beard
It has the same behavior on both Linux and WIN32.
It looks like the document at the top of the page is being drawn twice. one in
the correct position and once at the upper left corner of the window. Resizing
the window horizontally causes a small clipping rectangle to be applied near the
upper left corner that the second paint of the document is showing through.

Patrick, I'm going to re-assign to you since my best guess is that this is a
view problem. I don't think it's gfx since it has the same behavior on multiple
platforms.

Updated

19 years ago
Assignee: beard → rickg

Comment 6

19 years ago
This is a layout problem, not a rendering/view problem. The problem stems from
having a frame with a background image and a body with just an image element. The
problem is that in that case, tiling of a background image doesn't work. The
relevant frame in this page is:

http://www.image.dk/logo.html

In viewer/appRunner, the background image only draws in a narrow band down the
left of the window.

A simplified version of this frame is here:

<html>
<head>
<title>Image Background</title>
</head>
<body bgcolor="#ffffff" background="logoback2.gif" topmargin="1" leftmargin="1">
<img src="topleft.gif" hspace="0" vspace="0" border="0" align="left">
</body>
</html>

In Communicator 4.51 the image logoback2.gif is draw tiled in the background, and
topleft.gif is drawn over it. If some text is added to the body, right after the
image element, the tiling works:

<html>
<head>
<title>Image Background</title>
</head>
<body bgcolor="#ffffff" background="logoback2.gif" topmargin="1" leftmargin="1">
<img src="topleft.gif" hspace="0" vspace="0" border="0" align="left">
This is a test.
</body>
</html>

Pierre says this is a known bug, when a frame is empty, its width is computed
incorrectly. On the Mac, the width comes out to 8 pixels rather than the full
width of the browser window.

Updated

19 years ago
Assignee: rickg → karnaze

Comment 7

19 years ago
Chris -- see Patricks comments, they appear to indict the frame code.

Updated

19 years ago
Assignee: karnaze → kipp

Comment 8

19 years ago
The following illustrates the problem with no framesets involved. Reassigning to
Kipp.

<head>
<base href=http://www.image.dk>
</head>

<body bgcolor="#ffffff" background="/graphics/backgrounds/logoback2.gif"
topmargin="1" leftmargin="1">
<img src="http://www.image.dk/graphics/backgrounds/topleft.gif" hspace="0"
vspace="0" border="0" align="left">
</body>
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
Summary: www.image.dk menu does not render properly. small redraw error → {css1} www.image.dk menu does not render properly. small redraw error
Known problem.

*** This bug has been marked as a duplicate of 6630 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 10

19 years ago
Agreed. This is a duplicate of 6630.
Keywords: css1
Migrating from {css1} to css1 keyword. The {css1}, {css2}, {css3} and {css-moz}
radars should now be considered deprecated in favour of keywords.
I am *really* sorry about the spam...
You need to log in before you can comment on or make changes to this bug.