500 Internal Server Error ([5xx Error] File: application/libraries/drivers/Database/Pgsql.php; Line: 74; Message: pg_query(): Query failed: ERROR: out of shared memory) with aggregate Firefox-version query in /report/list

VERIFIED WORKSFORME

Status

Socorro
General
--
major
VERIFIED WORKSFORME
6 years ago
6 years ago

People

(Reporter: stephend, Unassigned)

Tracking

Bug Flags:
in-litmus +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

6 years ago
https://crash-stats.allizom.org/report/list?product=Firefox&version=Firefox%3A6.0%28beta%29&version=Firefox%3A6.0b5&version=Firefox%3A6.0b4&version=Firefox%3A6.0b3&version=Firefox%3A6.0b2&version=Firefox%3A6.0b1&version=Firefox%3A6.0a2&version=Firefox%3A6.0&query_search=signature&query_type=contains&reason_type=contains&date=08%2F15%2F2011%2023%3A29%3 bombs out; stack/exception coming soon.
Flags: in-testsuite?
Flags: in-litmus?
(Reporter)

Comment 1

6 years ago
Exception:

[5xx Error] File: application/libraries/drivers/Database/Pgsql.php; Line: 74; Message: pg_query(): Query failed: ERROR: out of shared memory
Summary: 500 Internal Server Error with aggregate Firefox-version query in /report/list → 500 Internal Server Error ([5xx Error] File: application/libraries/drivers/Database/Pgsql.php; Line: 74; Message: pg_query(): Query failed: ERROR: out of shared memory) with aggregate Firefox-version query in /report/list
(Reporter)

Comment 2

6 years ago
See also https://crash-stats.allizom.org/report/list?product=Firefox&query_search=signature&query_type=exact&reason_type=contains&date=08/15/2011%2015:46:05&range_value=4&range_unit=weeks&hang_type=any&process_type=any&do_query=1&missing_sig=EMPTY_STRING,

Comment 3

6 years ago
These are caused by running deliberately expensive queries: not for 2.2.1
Severity: critical → major
Target Milestone: --- → 2.3
(Reporter)

Comment 4

6 years ago
This also wfm, now; guessing it was "fixed" when we bumped up the memory limit.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
(In reply to Stephen Donner [:stephend] from comment #4)
> This also wfm, now; guessing it was "fixed" when we bumped up the memory
> limit.

wfm as well .. thanks stephend.
Status: RESOLVED → VERIFIED

Updated

6 years ago
Flags: in-testsuite?
Flags: in-testsuite-
Flags: in-litmus?
Flags: in-litmus+
(Assignee)

Updated

6 years ago
Component: Socorro → General
Product: Webtools → Socorro
You need to log in before you can comment on or make changes to this bug.