Last Comment Bug 679346 - js/src/jsdbgapi.cpp:1233: warning: ‘void UnsafeError(const char*, ...)’ defined but not used
: js/src/jsdbgapi.cpp:1233: warning: ‘void UnsafeError(const char*, ...)’ defin...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Other Branch
: x86 Mac OS X
: -- normal (vote)
: mozilla9
Assigned To: Jason Orendorff [:jorendorff]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-16 07:42 PDT by Jason Orendorff [:jorendorff]
Modified: 2011-08-17 04:43 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (556 bytes, patch)
2011-08-16 07:59 PDT, Jason Orendorff [:jorendorff]
gal: review+
Details | Diff | Review

Description Jason Orendorff [:jorendorff] 2011-08-16 07:42:16 PDT
Another GCC warning snuck in. Introduced by jsdbg2, probably.
Comment 1 Jason Orendorff [:jorendorff] 2011-08-16 07:59:02 PDT
Created attachment 553475 [details] [diff] [review]
v1

_GNU_SOURCE is a way for *programs* to specify which signatures they want[1] from GNU system headers that... anyway, it's not what you want here.

The compiler's preprocessor badge is __GNUC__.

[1] ...or something? if you care, read on:
    http://www.gnu.org/s/hello/manual/libc/Feature-Test-Macros.html
Comment 2 Jason Orendorff [:jorendorff] 2011-08-16 08:00:42 PDT
I forgot to mention, in case the war room is reading along here: it turns out
jsdbg2 is innocent! In fact, it's perfect in every way. Please don't back it out.
:)
Comment 3 Jason Orendorff [:jorendorff] 2011-08-16 09:38:21 PDT
hg.mozilla.org/integration/mozilla-inbound/rev/47ae156df73f
Comment 4 Steve Fink [:sfink] [:s:] 2011-08-16 12:10:08 PDT
The above link describes _GNU_SOURCE, but I needed to continue my edumification at http://gcc.gnu.org/onlinedocs/cpp/Common-Predefined-Macros.html

I think I knew this, but did a lazy grep for "GNU" and grabbed the first thing that looked relevant.

Thanks for the cleanup.
Comment 5 :Ehsan Akhgari (busy, don't ask for review please) 2011-08-17 04:43:29 PDT
http://hg.mozilla.org/mozilla-central/rev/47ae156df73f

Note You need to log in before you can comment on or make changes to this bug.