Last Comment Bug 679364 - Use either content/devtools/* or content/browser/devtools/* for aliases
: Use either content/devtools/* or content/browser/devtools/* for aliases
Status: RESOLVED FIXED
[good-first-bugs][lang=js][mentor=mik...
: addon-compat, dev-doc-complete
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Firefox 23
Assigned To: Brandon Benvie [:benvie]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-16 08:48 PDT by Michael Ratcliffe [:miker] [:mratcliffe]
Modified: 2013-07-08 16:03 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Use "content/browser/devtools/*" for aliases (15.82 KB, patch)
2013-02-21 06:54 PST, Brandon Benvie [:benvie]
rcampbell: review+
Details | Diff | Splinter Review
Use "content/browser/devtools/*" for aliases -- updated (16.26 KB, patch)
2013-02-25 10:59 PST, Brandon Benvie [:benvie]
no flags Details | Diff | Splinter Review
WIP3 (25.47 KB, patch)
2013-04-30 11:56 PDT, Brandon Benvie [:benvie]
no flags Details | Diff | Splinter Review

Description Michael Ratcliffe [:miker] [:mratcliffe] 2011-08-16 08:48:59 PDT
Dolske's comment from bug 582596:

::: browser/devtools/jar.mn
@@ +1,5 @@
>  browser.jar:
>      content/browser/NetworkPanel.xhtml            (webconsole/NetworkPanel.xhtml)
>  *   content/browser/scratchpad.xul                (scratchpad/scratchpad.xul)
>  *   content/browser/scratchpad.js                 (scratchpad/scratchpad.js)
> +    content/browser/csshtmltree.xhtml             (styleinspector/csshtmltree.xhtml)

I'd suggest having a "devtools" namespace here too. Either
content/devtools/* or content/browser/devtools/*.
Comment 1 Rob Campbell [:rc] (:robcee) 2012-11-02 09:38:00 PDT
looks like:

http://mxr.mozilla.org/mozilla-central/source/browser/devtools/jar.mn

still has some non-devtools-prefixed stuff. Would be good to get these cleaned up.

Making this a good first bug.
Comment 2 AL 2012-11-09 19:30:20 PST
I'm looking to get involved with Mozilla. Should I start working on this bug? Also, a little bit more of an explanation would be helpful.

Thanks!
Comment 3 Rob Campbell [:rc] (:robcee) 2012-12-28 11:22:20 PST
this is still a bug.

AL, it would be great if you could help out with this. Miker should be able to get you rolling on it.
Comment 4 Brandon Benvie [:benvie] 2013-02-20 06:43:20 PST
I'm going to go ahead and take this.
Comment 5 Brandon Benvie [:benvie] 2013-02-21 06:54:27 PST
Created attachment 716524 [details] [diff] [review]
Use "content/browser/devtools/*" for aliases
Comment 6 Victor Porof [:vporof][:vp] 2013-02-21 07:25:33 PST
(In reply to Brandon Benvie [:bbenvie] from comment #5)
> Created attachment 716524 [details] [diff] [review]
> Use "content/browser/devtools/*" for aliases

Thank you so much for aligning everything in jar.mn. It was driving me crazy!
Comment 7 Rob Campbell [:rc] (:robcee) 2013-02-21 08:49:57 PST
Comment on attachment 716524 [details] [diff] [review]
Use "content/browser/devtools/*" for aliases

Review of attachment 716524 [details] [diff] [review]:
-----------------------------------------------------------------

looks good!

(and yes. aligning jar.mn was properly righteous)
Comment 8 Brandon Benvie [:benvie] 2013-02-21 10:47:15 PST
Alignment is an utmost priority!
Comment 9 Paul Rouget [:paul] 2013-02-25 05:20:49 PST
https://hg.mozilla.org/integration/fx-team/rev/824b68f13f30
Comment 10 Brandon Benvie [:benvie] 2013-02-25 10:59:58 PST
Created attachment 717972 [details] [diff] [review]
Use "content/browser/devtools/*" for aliases -- updated

Fixes the regression where one reference to profiler.xul was missed.
Comment 11 Rob Campbell [:rc] (:robcee) 2013-02-25 11:34:38 PST
backed out in:

https://hg.mozilla.org/integration/fx-team/rev/98bb8bc5c30b

congrats Brandon! First backout!
Comment 12 Rob Campbell [:rc] (:robcee) 2013-02-25 12:41:45 PST
Comment on attachment 717972 [details] [diff] [review]
Use "content/browser/devtools/*" for aliases -- updated

Need one additional change in ProfilerPanel.jsm, line 58:

  this.iframe.setAttribute("src", "cleopatra.html?" + uid);

(remove devtools/ since we're already at the same relative depth).
Comment 13 Paul Rouget [:paul] 2013-03-14 10:53:56 PDT
Any update on that?
Comment 14 Brandon Benvie [:benvie] 2013-03-27 09:12:34 PDT
Can't believe I missed this.
Comment 15 Victor Porof [:vporof][:vp] 2013-04-18 10:23:45 PDT
How's this looking? Can we land it?
Comment 16 Brandon Benvie [:benvie] 2013-04-30 11:56:50 PDT
Created attachment 743766 [details] [diff] [review]
WIP3

Finally got back to this. https://tbpl.mozilla.org/?tree=Try&rev=08504b940ae5
Comment 17 Brandon Benvie [:benvie] 2013-05-01 09:36:02 PDT
Looks like all the failures are from other intermittent crashers.
Comment 18 Rob Campbell [:rc] (:robcee) 2013-05-06 16:16:48 PDT
https://hg.mozilla.org/integration/fx-team/rev/4a068034be50
Comment 19 Girish Sharma [:Optimizer] 2013-05-06 21:57:53 PDT
This is not resolved fixed yet :)
Comment 20 Tim Taubert [:ttaubert] (on PTO, back Aug 29th) 2013-05-07 00:19:42 PDT
https://hg.mozilla.org/mozilla-central/rev/4a068034be50
Comment 21 Jorge Villalobos [:jorgev] 2013-07-08 16:03:50 PDT
This has minor add-on compatibility implications, and has been documented already: https://developer.mozilla.org/en-US/docs/Mozilla/Firefox/Releases/23#Firefox_Developer_Tools

Note You need to log in before you can comment on or make changes to this bug.