view source only shows 1024 characters of string values correctly

RESOLVED DUPLICATE of bug 16688

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 16688
17 years ago
17 years ago

People

(Reporter: bz, Assigned: Chris Waterson)

Tracking

Trunk
mozilla1.0.1
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

BUILD: linux build 2001020512

STEPS TO REPRODUCE:
1) load attached testcase
2) view the source

EXPECTED RESULTS:
href values and keywords for meta tag shown completely

ACTUAL RESULTS:
only the first 1024 characters are shown correctly.  The first href has 1023
'a's followed by three 'b's.  The second has 1023 'a's followed by three 'b's.

The characters after the 1024th one overlap the text that follows the string.

only the first 1024 chars of the meta tag's content are shown; the rest are all
collapsed together.
is there some hardcoded limit to what we could display here for a text area?

charley or rod, should this go over to one of the layout components?

Comment 3

17 years ago
I'm not seeing this problem with my debug build (current as of 2/6/01) or the
NS 6 release.
I don't think there's any limitation imposed by a textfield, but I don't think
that has anything to do with this anyway. Isn't the "View Source" output simply
an output string (HTML conversion) displayed in a window (i.e., no textfield
is involved)?
Note that the "View Source" for Browser has nothing to do with "View Source"
in Composer, which is editable and thus uses a textfield.
This should probably go to whoever owns view source for browser (not sure
who that is).
bill, not sure if this would fall into your area, but...

Comment 5

17 years ago
The problem is likely in the Linux widget code, I suspect.  If it were layout,
then we'd see it on all platforms.  It definitely isn't xpapps, so I'm
reassigning to the owner of XP Toolkit/Widgets.
Assignee: vishy → trudelle
Component: XP Apps → XP Toolkit/Widgets
QA Contact: sairuh → jrgm

Updated

17 years ago
Blocks: 57724

Comment 6

17 years ago
I don't see this in recent Linux builds, and I don't see why any widgets would
be involved in any case. resolving as wfm, 
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
OK... I tested this some more with linux build 2001-02-26-08.  Here is more
detail on what I am seeing:

1)  With the default preferences, the ends of the really long lines are simply
truncated.

2)  With user_pref("browser.view_source.syntax_highlight", true); I see the
behavior described above in this bug.

Attaching screenshots of both.  
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Created attachment 26301 [details]
No syntax highlighting
Created attachment 26302 [details]
Syntax highlighting

Comment 10

17 years ago
That's not truncation, it is just not wrapping. The text is all there, you can
verify by using select/paste.  The second example looks like a layout issue,
which sounds like where this bug should really go.  ->layout.
Assignee: trudelle → karnaze
Status: REOPENED → NEW
Component: XP Toolkit/Widgets → Layout
QA Contact: jrgm → petersen

Comment 11

17 years ago
is this a dupe of the bug about not adding scrollbars for dynamic content?
*** Bug 73563 has been marked as a duplicate of this bug. ***

Comment 13

17 years ago
Reassigning to waterson and moving to m1.0.1
Assignee: karnaze → waterson
Target Milestone: --- → mozilla1.0.1
For another testcase, not using quotes, see
http://bugzilla.mozilla.org/showattachment.cgi?attach_id=31831

Just load that and do view source.

Comment 15

17 years ago
This bug is happening because the gfx code

*** This bug has been marked as a duplicate of 16688 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE
No longer blocks: 57724
You need to log in before you can comment on or make changes to this bug.