The default bug view has changed. See this FAQ.

Create some BMP reftests for OS/2 bitmaps

RESOLVED FIXED in mozilla9

Status

()

Core
ImageLib
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: bbondy, Assigned: bbondy)

Tracking

Trunk
mozilla9
x86_64
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
We have very good coverage of BMP decoders via Bug 600556, but not yet any coverage for OS/2 bitmaps.  These are bitmaps with an information header of 12 bytes instead of 40 bytes. 

We should have support for OS2 bitmaps for Bit per pixels
- 1
- 4
- 8 
- 24

Since OS/2 bitmaps do not have compression, we should only need the basic equivalent tests for our current coverage.

I can't seem to find an image editing software that allows you to encode in a specific way for OS/2 bitmaps but what I will do is use a hex editor to manually generate the input test OS/2 bitmap headers, and use the equivalent data from the normal BMP handling code.   After making sure with other programs that they are correct I will implement the reftests.
(Assignee)

Updated

6 years ago
Assignee: nobody → netzen
(Assignee)

Updated

6 years ago
Depends on: 600556
(Assignee)

Updated

6 years ago
OS: Windows 7 → All
(Assignee)

Comment 1

6 years ago
Created attachment 553787 [details] [diff] [review]
REftests for OS/2 BMPs

Since just the Bitmap Information Header changes, and the color table changes, but not the data handling for OS/2 bitmaps vs MS bitmaps.  I did just one ref test per Bit Per Pixel value.  

I also did a test for an invalid OS/2 Bit Per Pixel value.

I did these ref tests because I wanted to be sure that my BMP refactoring did not cause any regressions and that we had proper handling in general for OS/2 bitmaps.
Attachment #553787 - Flags: review?(joe)
(Assignee)

Updated

6 years ago
Blocks: 679725
Attachment #553787 - Flags: review?(joe) → review+
(Assignee)

Comment 2

6 years ago
Pushed to mozilla-inbound:

http://hg.mozilla.org/integration/mozilla-inbound/rev/db59a3f2f661
http://hg.mozilla.org/mozilla-central/rev/db59a3f2f661
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla9
You need to log in before you can comment on or make changes to this bug.