test-content-proxy.testProxy triggers assertion in jscntxtinlines.h

RESOLVED WORKSFORME

Status

Add-on SDK
General
P2
normal
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: myk, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Some test, which looks like test-content-proxy.testProxy, is triggering an assertion on debug builds from the central and aurora repositories for all OSes, for example in this test run <http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Aurora/1313453895.1313454650.19515.gz&fulltext=1>:

info: executing 'test-content-proxy.testProxy'
...
info: pass: origin is null
*** Compartment mismatch 0xb305280 vs. 0xa0ca928
Assertion failure: compartment mismatched, at ../../../js/src/jscntxtinlines.h:123
Traceback (most recent call last):
  File "bin/cfx", line 29, in <module>
    cuddlefish.run()
  File "/home/cltbld/talos-slave/test/build/addon-sdk-9f45975c909d/python-lib/cuddlefish/__init__.py", line 492, in run
    test_all(env_root, defaults=options.__dict__)
  File "/home/cltbld/talos-slave/test/build/addon-sdk-9f45975c909d/python-lib/cuddlefish/__init__.py", line 323, in test_all
    test_all_packages(env_root, defaults)
  File "/home/cltbld/talos-slave/test/build/addon-sdk-9f45975c909d/python-lib/cuddlefish/__init__.py", line 379, in test_all_packages
    defaults=defaults)
  File "/home/cltbld/talos-slave/test/build/addon-sdk-9f45975c909d/python-lib/cuddlefish/__init__.py", line 790, in run
    norun=options.no_run)
  File "/home/cltbld/talos-slave/test/build/addon-sdk-9f45975c909d/python-lib/cuddlefish/runner.py", line 399, in run_app
    timeout)
Exception: Wait timeout exceeded (600s)

This seems likely to be caused by platform bug 679494.  Note that the line in jscntxtinlines.h that triggers the assertion is 120 on central but 123 on aurora (as of shortly before today's merge; it's probably the same on both now).
(Reporter)

Updated

7 years ago
Priority: -- → P2
Target Milestone: --- → 1.4
(Pushing all open bugs to the --- milestone for the new triage system)
Target Milestone: 1.4 → ---
(Reporter)

Updated

6 years ago
Depends on: 699532
(Reporter)

Updated

6 years ago
No longer depends on: 699532
(Reporter)

Comment 3

6 years ago
I just took a look at a bunch of instances of this, and it turns out they're all occurring on the beta and/or release branches, not on central nor aurora.  So perhaps this has actually already been fixed?
(Reporter)

Updated

6 years ago
Whiteboard: [triage:followup]
Is this still happening?
I don't think so, Wes?

Wes: Are we still facing intermittent failure due to jetpack codebase?
From what I'm seing these days, we only face tbpl specific issues,
where it fails downloading firefox tarball.
(In reply to Alexandre Poirot (:ochameau) from comment #5)
> I don't think so, Wes?
> 
> Wes: Are we still facing intermittent failure due to jetpack codebase?
> From what I'm seing these days, we only face tbpl specific issues,
> where it fails downloading firefox tarball.

I haven't seen this issue for a while, though there are still some intermittent test failures and timeouts elsewhere.
Sounds like this is fixed, we can reopen if not.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.