Remove config/gtscc.c

RESOLVED FIXED in Firefox 9

Status

()

Firefox
Build Config
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: David Volgyes, Assigned: Matheus Kerschbaum)

Tracking

(Blocks: 1 bug)

Trunk
Firefox 9
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:6.0) Gecko/20100101 Firefox/6.0
Build ID: 20110812233755

Steps to reproduce:

cppcheck found some memory leak in gtscc.c.


Actual results:

These are the reported leaks:
[firefox-src/config/gtscc.c:764]: (error) Memory leak: source
[firefox-src/config/gtscc.c:764]: (error) Memory leak: object
[firefox-src/config/gtscc.c:1247]: (error) Memory leak: archive
[firefox-src/config/gtscc.c:2506]: (error) Memory leak: table
[firefox-src/config/gtscc.c:2506]: (error) Memory leak: dmap



Expected results:

You should release the objects before exit point. 

However, these bugs are not too importants, because the itself a program, and the memory will be released, when the program ends.

Updated

6 years ago
Blocks: 679417

Updated

6 years ago
Component: General → Build Config
QA Contact: general → build.config
There aren't even rules to build that program.
And the rules to do so have been removed in ... 1999.
http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&file=Makefile.in&branch=3.26&root=/cvsroot&subdir=mozilla/config&command=DIFF_FRAMESET&rev1=3.25&rev2=3.26
Someone should just hg rm it.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: memory leaks in config/gtscc.c → Remove config/gtscc.c
and remove the reference in the packager.mk.
(Reporter)

Comment 5

6 years ago
(In reply to Mike Hommey [:glandium] from comment #1)
> There aren't even rules to build that program.

That highlights a drawback of cppcheck: 
cppcheck does not use makefile (or other rule file), it is just scan all the source files, so it produces warning for unused files too. 

Maybe a cleanup would be useful. Probably there are some other unused files in the trunk.
(Assignee)

Comment 6

6 years ago
Created attachment 553969 [details] [diff] [review]
patch
Attachment #553969 - Flags: review?(ted.mielczarek)

Updated

6 years ago
Assignee: nobody → matjk7
Status: NEW → ASSIGNED
Comment on attachment 553969 [details] [diff] [review]
patch

Review of attachment 553969 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #553969 - Flags: review?(ted.mielczarek) → review+
(Assignee)

Updated

6 years ago
Keywords: checkin-needed
OS: Linux → All
Hardware: x86_64 → All
http://hg.mozilla.org/integration/mozilla-inbound/rev/5d5f7e60a322
Flags: in-testsuite-
Target Milestone: --- → Firefox 9

Updated

6 years ago
Keywords: checkin-needed

Comment 9

6 years ago
http://hg.mozilla.org/mozilla-central/rev/5d5f7e60a322
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.