Last Comment Bug 679689 - ASSERTION: Empty string? trying to parse HTML image with empty crossorigin attribute
: ASSERTION: Empty string? trying to parse HTML image with empty crossorigin at...
Status: RESOLVED FIXED
: assertion
Product: Core
Classification: Components
Component: DOM: Core & HTML (show other bugs)
: Trunk
: x86 Windows 2000
: P1 normal (vote)
: mozilla9
Assigned To: Boris Zbarsky [:bz] (still a bit busy)
:
: Andrew Overholt [:overholt]
Mentors:
http://maps.google.fr/maps?q=rue+de+l...
Depends on:
Blocks: 676413
  Show dependency treegraph
 
Reported: 2011-08-17 06:36 PDT by neil@parkwaycc.co.uk
Modified: 2011-09-01 02:00 PDT (History)
8 users (show)
bzbarsky: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
WinDbg stack trace (885 bytes, text/plain)
2011-08-17 06:38 PDT, neil@parkwaycc.co.uk
no flags Details
testcase (34 bytes, text/html)
2011-08-22 16:41 PDT, Jesse Ruderman
no flags Details
Allow empty string values to be associtated to enumerated attributes. (2.41 KB, patch)
2011-08-24 11:56 PDT, Boris Zbarsky [:bz] (still a bit busy)
jonas: review+
Details | Diff | Splinter Review

Description neil@parkwaycc.co.uk 2011-08-17 06:36:44 PDT
I hit this assertion and according to the local variables on the stack the SetAttr in question has a name of "crossorigin" and an empty value.
Comment 1 neil@parkwaycc.co.uk 2011-08-17 06:38:28 PDT
Created attachment 553748 [details]
WinDbg stack trace
Comment 2 neil@parkwaycc.co.uk 2011-08-17 06:44:15 PDT
Looks like they also set it to the empty string in script too...
Comment 3 Jesse Ruderman 2011-08-22 16:41:46 PDT
Created attachment 554988 [details]
testcase
Comment 4 Boris Zbarsky [:bz] (still a bit busy) 2011-08-23 22:18:00 PDT
nsAttrValue::SetMiscAtomOrString has this code:

    PRUint32 len = aValue->Length();
    // We're allowing eCSSStyleRule attributes to store empty strings as it
    // can be beneficial to store an empty style attribute as a parsed rule.
    // Add other types as needed.
    NS_ASSERTION(len || Type() == eCSSStyleRule, "Empty string?");

Jonas, sounds like we should add enumerated types here, right?
Comment 5 Jonas Sicking (:sicking) No longer reading bugmail consistently 2011-08-24 07:57:14 PDT
Yeah
Comment 6 Boris Zbarsky [:bz] (still a bit busy) 2011-08-24 11:56:30 PDT
Created attachment 555477 [details] [diff] [review]
Allow empty string values to be associtated to enumerated attributes.
Comment 7 Ed Morley [:emorley] 2011-08-31 17:05:22 PDT
Something in this push caused orange, so backed out of inbound:
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&usebuildbot=1&rev=89b87e96dc17
http://hg.mozilla.org/integration/mozilla-inbound/rev/b449db7a038b
Comment 8 Boris Zbarsky [:bz] (still a bit busy) 2011-08-31 21:15:12 PDT
The orange was something else.  Pushed http://hg.mozilla.org/integration/mozilla-inbound/rev/aa18f8632882
Comment 9 Ed Morley [:emorley] 2011-09-01 02:00:02 PDT
http://hg.mozilla.org/mozilla-central/rev/aa18f8632882

Note You need to log in before you can comment on or make changes to this bug.