Last Comment Bug 679791 - nsIFrame::IsFocusable incorrectly uses the absolute size of scrollbars to determine if a scrollable frame should be focusable
: nsIFrame::IsFocusable incorrectly uses the absolute size of scrollbars to det...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Layout (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla9
Assigned To: Josh Matthews [:jdm] (on vacation until Dec 5)
:
: Jet Villegas (:jet)
Mentors:
Depends on:
Blocks: 668283
  Show dependency treegraph
 
Reported: 2011-08-17 10:52 PDT by Josh Matthews [:jdm] (on vacation until Dec 5)
Modified: 2011-08-24 17:29 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Make nsIFrame::IsFocusable use heuristics that don't depend on the graphical display of scrollbars. (1.07 KB, patch)
2011-08-17 11:03 PDT, Josh Matthews [:jdm] (on vacation until Dec 5)
roc: review+
Details | Diff | Splinter Review

Description Josh Matthews [:jdm] (on vacation until Dec 5) 2011-08-17 10:52:28 PDT
In fennec, we don't show scrollbars, so content/events/test_bug409604.html fails when trying to focus a scrollable div.
Comment 1 Josh Matthews [:jdm] (on vacation until Dec 5) 2011-08-17 11:03:10 PDT
Created attachment 553835 [details] [diff] [review]
Make nsIFrame::IsFocusable use heuristics that don't depend on the graphical display of scrollbars.

Waiting on try results before requesting review.
Comment 2 Josh Matthews [:jdm] (on vacation until Dec 5) 2011-08-18 11:14:27 PDT
Comment on attachment 553835 [details] [diff] [review]
Make nsIFrame::IsFocusable use heuristics that don't depend on the graphical display of scrollbars.

Try looks like all known oranges. Boris, you reviewed a similar change for David Bolter, so you seem like a reasonable reviewer choice to me.
Comment 3 Boris Zbarsky [:bz] (still a bit busy) 2011-08-23 22:35:48 PDT
Comment on attachment 553835 [details] [diff] [review]
Make nsIFrame::IsFocusable use heuristics that don't depend on the graphical display of scrollbars.

Actually, I think roc should look at this one.  It's not clear to me whether this is the right way to test for "overflow:auto that actually overflows"...
Comment 4 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-08-23 22:51:40 PDT
Comment on attachment 553835 [details] [diff] [review]
Make nsIFrame::IsFocusable use heuristics that don't depend on the graphical display of scrollbars.

Review of attachment 553835 [details] [diff] [review]:
-----------------------------------------------------------------

Yeah, I think this is what I would have written :-).
Comment 5 Josh Matthews [:jdm] (on vacation until Dec 5) 2011-08-24 07:20:02 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/9e0f8a7cc1a0
Comment 6 Matt Brubeck (:mbrubeck) 2011-08-24 17:29:28 PDT
http://hg.mozilla.org/mozilla-central/rev/9e0f8a7cc1a0

Note You need to log in before you can comment on or make changes to this bug.