Last Comment Bug 679796 - js_DumpStackFrame should walk saved frame chains
: js_DumpStackFrame should walk saved frame chains
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: mozilla9
Assigned To: Benjamin Smedberg [:bsmedberg]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-17 11:01 PDT by Benjamin Smedberg [:bsmedberg]
Modified: 2011-08-21 11:41 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Make js_DumpStackFrame traverse saved frame chains, rev. 1 (2.25 KB, patch)
2011-08-17 11:03 PDT, Benjamin Smedberg [:bsmedberg]
luke: review+
Details | Diff | Review

Description Benjamin Smedberg [:bsmedberg] 2011-08-17 11:01:07 PDT
I was trying to use js_DumpStackFrame. But the request/context was suspended, because we suspect contexts whenever we call from JS->XPCOM through xpconnect, which means that the top frame was actually null. This patch changes js_DumpStackFrame to walk suspended frame chains also, which is I think what people will usually want/expect.
Comment 1 Benjamin Smedberg [:bsmedberg] 2011-08-17 11:03:05 PDT
Created attachment 553834 [details] [diff] [review]
Make js_DumpStackFrame traverse saved frame chains, rev. 1
Comment 2 Luke Wagner [:luke] 2011-08-17 11:14:16 PDT
Comment on attachment 553834 [details] [diff] [review]
Make js_DumpStackFrame traverse saved frame chains, rev. 1

Review of attachment 553834 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks

Note You need to log in before you can comment on or make changes to this bug.