The default bug view has changed. See this FAQ.

Change JSFunction macros to methods

RESOLVED FIXED in mozilla9

Status

()

Core
JavaScript Engine
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: jorendorff, Assigned: jorendorff)

Tracking

Other Branch
mozilla9
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [inbound])

Attachments

(2 attachments)

Comment hidden (empty)
(Assignee)

Comment 1

6 years ago
Created attachment 553905 [details] [diff] [review]
part 2, js/src - v1
Assignee: general → jorendorff
Attachment #553905 - Flags: review?(jwalden+bmo)
(Assignee)

Comment 2

6 years ago
Created attachment 553934 [details] [diff] [review]
part 1, caps - v1

Use JS_GetPrivate rather than GET_FUNCTION_PRIVATE in caps.
Attachment #553934 - Flags: review?(mrbkap)
(Assignee)

Updated

6 years ago
Attachment #553905 - Attachment description: v1 → part 2, js/src - v1

Updated

6 years ago
Attachment #553934 - Flags: review?(mrbkap) → review+
Comment on attachment 553905 [details] [diff] [review]
part 2, js/src - v1

Review of attachment 553905 [details] [diff] [review]:
-----------------------------------------------------------------

::: js/src/jsapi.cpp
@@ +4355,5 @@
>               * As jsapi.h notes, fs must point to storage that lives as long
>               * as fun->object lives.
>               */
>              Value priv = PrivateValue(fs);
> +            if (!js_SetReservedSlot(cx, fun, 0, priv))

You could make this fun->setReservedSlot(0, priv) now, right?

::: js/src/jsfun.h
@@ +229,5 @@
>      static const uint32 CLASS_RESERVED_SLOTS = JSObject::FUN_CLASS_RESERVED_SLOTS;
> +
> +
> +    js::Class *getConstructorClass() const {
> +        JS_ASSERT(!isInterpreted());

isNative() seems more to the point here, to me.

@@ +234,5 @@
> +        return u.n.clasp;
> +    }
> +
> +    void setConstructorClass(js::Class *clasp) {
> +        JS_ASSERT(!isInterpreted());

And here.

@@ +239,5 @@
> +        u.n.clasp = clasp;
> +    }
> +
> +    JSNativeTraceInfo *getTraceInfo() {
> +        JS_ASSERT(!isInterpreted());

And here.
Attachment #553905 - Flags: review?(jwalden+bmo) → review+
(Assignee)

Comment 4

6 years ago
http://hg.mozilla.org/integration/mozilla-inbound/rev/a5c778f36c33
http://hg.mozilla.org/integration/mozilla-inbound/rev/1dccbc1234f4
Whiteboard: [inbound]
http://hg.mozilla.org/mozilla-central/rev/a5c778f36c33
http://hg.mozilla.org/mozilla-central/rev/1dccbc1234f4
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla9

Updated

6 years ago
Depends on: 680755
(Assignee)

Updated

6 years ago
Duplicate of this bug: 513014
You need to log in before you can comment on or make changes to this bug.