Preopen connections based on a domain's previous connection history

RESOLVED DUPLICATE of bug 881804

Status

()

RESOLVED DUPLICATE of bug 881804
7 years ago
4 years ago

People

(Reporter: jduell.mcbugs, Assigned: sworkman)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
We're going to be keeping DNS info on which hostnames are usually resolved when a given host is requested (i.e. ads.cnn.com needed whenever www.cnn.com requested).  See bug 580104.

We could piggyback off that same data and actually pre-open TCP connections to those hosts.  Also, we could keep a tally of how many connections we generally wind up opening per host, and preopen more than 1 if we think we'll need them.  This applies to not just subdomains, but the original host too.

So I'm thinking we wind up searching leveldb for the original host (www.foo.com), and wind up getting a record (or records that add up to): 

1) how many TCP cxns to open to www.foo.com
2) which subdomains (bar.foo.com, etc.) to open, and how many cxns for each.

I'm not sure whether the right way to do this is to store all this in one db entry, or have the cxn count for subdomains be stored in their own entry (which requires multiple queries, but centralizes the info).
(Reporter)

Updated

7 years ago
Assignee: nobody → sjhworkman
(Reporter)

Comment 1

7 years ago
Steve, I'm assigning this to you for now just because it'll leverage the same leveldb database we'll use for bug 580104.
(Reporter)

Comment 2

7 years ago
Sounds like chromium uses a 10 second timeout for "preconnected sockets":

   http://code.google.com/p/chromium/issues/detail?id=84313#c13

I.e. they're closed if they're not used within 10s.  

Apparently they've got this turned on by default and controlled by a setting called "Use a prediction service to help complete searches and URLs typed in the address bar"
Duping this to bug 881804, as the work on predictive connections is being discussed there.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 881804
You need to log in before you can comment on or make changes to this bug.