Last Comment Bug 679994 - checkboxes in "disable add-ons you no longer use" dialog have no labels, names aren't accessible
: checkboxes in "disable add-ons you no longer use" dialog have no labels, name...
Status: VERIFIED FIXED
: access, sec508
Product: Toolkit
Classification: Components
Component: Add-ons Manager (show other bugs)
: Trunk
: All All
: -- major (vote)
: mozilla9
Assigned To: Blair McBride [:Unfocused] (UNAVAILABLE)
:
Mentors:
Depends on:
Blocks: 680363 596343
  Show dependency treegraph
 
Reported: 2011-08-17 22:32 PDT by Marco Zehe (:MarcoZ)
Modified: 2013-12-27 14:36 PST (History)
9 users (show)
blair: in‑testsuite-
blair: in‑litmus-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
fixed


Attachments
Checkbox mockup (8.36 KB, image/gif)
2011-08-22 04:57 PDT, neil@parkwaycc.co.uk
no flags Details
Patch v1 (2.54 KB, patch)
2011-09-26 04:26 PDT, Blair McBride [:Unfocused] (UNAVAILABLE)
robert.strong.bugs: review+
jboriss: ui‑review+
asa: approval‑mozilla‑aurora+
asa: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description Marco Zehe (:MarcoZ) 2011-08-17 22:32:43 PDT
When updating my nightly build from 8.0a1 to 9.0a1, I got the dialog saying "Disable add-ons you no longer use". There is a series of checkboxes I can tab through, and none of them have accessible names. I suspect these somehow label the different add-ons, but the link between the checkbox and the corresponding label isn't there. Thus, screen reader users have no way of knowing which ones are checked or not.
Comment 1 Dão Gottwald [:dao] 2011-08-18 00:53:14 PDT
Somewhat related to this: clicking the labels also doesn't (un)check their corresponding checkboxes.
Comment 2 Blair McBride [:Unfocused] (UNAVAILABLE) 2011-08-19 00:16:35 PDT
(In reply to Dão Gottwald [:dao] from comment #1)
> Somewhat related to this: clicking the labels also doesn't (un)check their
> corresponding checkboxes.

Filed bug 680363 for this.
Comment 3 neil@parkwaycc.co.uk 2011-08-22 04:44:49 PDT
Also somewhat related to this, there's no keyboard focus indication outline.
Comment 4 neil@parkwaycc.co.uk 2011-08-22 04:57:28 PDT
Created attachment 554825 [details]
Checkbox mockup

I used DOM Inspector to rearrange the document resulting in this mockup.

The checkboxes are now real checkboxes so that would help with both screen reader and keyboard accessibility.

I'm not sure what to do about a long translation of the word "Keep" though. (Currently it would just push the "Name" header over...)

The other alternative I was pondering was replacing the grid with a tree, however in this case it wouldn't be possible to eat into the icon space with the "Keep" header.
Comment 5 Dave Townsend [:mossop] 2011-08-23 12:00:10 PDT
(In reply to neil@parkwaycc.co.uk from comment #4)
> Created attachment 554825 [details]
> Checkbox mockup
> 
> I used DOM Inspector to rearrange the document resulting in this mockup.
> 
> The checkboxes are now real checkboxes so that would help with both screen
> reader and keyboard accessibility.
> 
> I'm not sure what to do about a long translation of the word "Keep" though.
> (Currently it would just push the "Name" header over...)

I guess we could just have a hidden label for the checkboxes and then somehow hide the actual name label from accessibility tools?

> The other alternative I was pondering was replacing the grid with a tree,
> however in this case it wouldn't be possible to eat into the icon space with
> the "Keep" header.

Last I checked the checkboxes in trees looked decidedly non-native too, otherwise I'd have loved to use a tree here, it would have saved a lot of problems.
Comment 6 Asa Dotzler [:asa] 2011-09-22 14:59:54 PDT
Who can fix this?
Comment 7 Blair McBride [:Unfocused] (UNAVAILABLE) 2011-09-26 04:26:43 PDT
Created attachment 562399 [details] [diff] [review]
Patch v1

Sometimes, the simplest of solutions works. Tested using NVDA. 

Patch also adds focus indication on the checkboxes (and only the checkboxes, to save re-doing a lot of the code).
Comment 8 Robert Strong [:rstrong] (use needinfo to contact me) 2011-09-26 14:56:46 PDT
Comment on attachment 562399 [details] [diff] [review]
Patch v1

Didn't review beyond a casual inspection and it looks fine. I'd prefer it if someone that works on theme code more than I reviewed the css and I am fine if the checkboxes now have a tooltip but if they do you should make sure UX is ok with it.
Comment 9 Blair McBride [:Unfocused] (UNAVAILABLE) 2011-09-26 18:40:55 PDT
https://hg.mozilla.org/integration/fx-team/rev/5607a7df7a93
Comment 10 Tim Taubert [:ttaubert] 2011-09-27 04:36:22 PDT
https://hg.mozilla.org/mozilla-central/rev/5607a7df7a93
Comment 11 Blair McBride [:Unfocused] (UNAVAILABLE) 2011-10-03 19:00:29 PDT
Comment on attachment 562399 [details] [diff] [review]
Patch v1

Should probably have this on beta (ie, 8), since that's the first version people will see this dialog. 

Simple patch - main part is just adding a tooltip. But it makes a huge difference to the accessibility of the dialog.
Comment 12 Vlad [QA] 2011-10-10 07:23:17 PDT
Hi guys.
How can I verify this? It's enough to update from nightly build 9.0a1 to 10.0a1 and see that the checkboxes are functional?
Thanks
Comment 13 Dave Townsend [:mossop] 2011-10-10 10:01:29 PDT
(In reply to Vlad [QA] from comment #12)
> Hi guys.
> How can I verify this? It's enough to update from nightly build 9.0a1 to
> 10.0a1 and see that the checkboxes are functional?
> Thanks

Before the upgrade make sure that extensions.shownSelectionUI is false and it'd be ideal to upgrade with a screenreader installed as Blair did to make sure it is reading things out correctly.
Comment 14 Henrik Skupin (:whimboo) 2011-10-10 13:01:50 PDT
Marco, would you be so kind to verify this fix? You are the reporter and probably the best person here for this task. Thanks so much.
Comment 15 Marco Zehe (:MarcoZ) 2011-10-10 23:31:12 PDT
Meant to verify this after I upgraded to 10.0a1, but got distracted. This is definitely fixed in the 10.0a1 nightly builds. Current build identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111007 Firefox/10.0a1
Comment 16 Blair McBride [:Unfocused] (UNAVAILABLE) 2011-10-12 04:00:26 PDT
https://hg.mozilla.org/releases/mozilla-beta/rev/46691e6ce598

(This was already on Aurora, as it landed on Central before the last merge.)

Note You need to log in before you can comment on or make changes to this bug.