Last Comment Bug 680043 - GCLI startup has too many dependencies for both content and chrome
: GCLI startup has too many dependencies for both content and chrome
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks: GCLI-JS
  Show dependency treegraph
 
Reported: 2011-08-18 04:04 PDT by Joe Walker [:jwalker] (needinfo me or ping on irc)
Modified: 2011-08-22 00:52 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-08-18 04:04:15 PDT
In order to get things started you need to require both 'gcli/index' and a custom startup for content and chrome. This spreads around the dependencies and make is harder to work out what goes where.

Since gcli/index is tiny, we should have 2 startup files. One for chrome and the other for content. This makes it clear where things live.

Note You need to log in before you can comment on or make changes to this bug.