Last Comment Bug 680117 - Footer string in the new Add-on selection window should wrap to fit long localizations
: Footer string in the new Add-on selection window should wrap to fit long loca...
Status: VERIFIED FIXED
[qa!]
: verified-beta
Product: Toolkit
Classification: Components
Component: Add-ons Manager (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla9
Assigned To: Blair McBride [:Unfocused] (mostly unavailable, needinfo open, reviews not)
:
Mentors:
Depends on:
Blocks: 596343
  Show dependency treegraph
 
Reported: 2011-08-18 09:23 PDT by Francesco Lodolo [:flod] - OFFLINE Jun 26-Jul 3
Modified: 2011-10-13 10:56 PDT (History)
10 users (show)
bmcbride: in‑testsuite-
bmcbride: in‑litmus-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
fixed


Attachments
Current add-on selection window in Italian nightlies (83.89 KB, image/png)
2011-08-18 09:25 PDT, Francesco Lodolo [:flod] - OFFLINE Jun 26-Jul 3
no flags Details
Patch v1 (1.27 KB, patch)
2011-08-18 23:38 PDT, Blair McBride [:Unfocused] (mostly unavailable, needinfo open, reviews not)
dtownsend: review+
blizzard: approval‑mozilla‑aurora+
Details | Diff | Review

Description Francesco Lodolo [:flod] - OFFLINE Jun 26-Jul 3 2011-08-18 09:23:35 PDT
In Italian we have a very long localization for the footer string "You can always change your add-ons by going to the Add-ons Manager." (footer.label in /chrome/mozapps/extensions/selectAddons.dtd).

In the second page of the wizard this string is displayed with two buttons ("Back" and "Done"), so in order to fit all elements we have a very wide window (128ch vs 93ch in en-US). If this string could wrap on two lines and leave enough space for the buttons, we could use a much narrower window.
Comment 1 Francesco Lodolo [:flod] - OFFLINE Jun 26-Jul 3 2011-08-18 09:25:05 PDT
Created attachment 554112 [details]
Current add-on selection window in Italian nightlies
Comment 2 Blair McBride [:Unfocused] (mostly unavailable, needinfo open, reviews not) 2011-08-18 23:38:34 PDT
Created attachment 554319 [details] [diff] [review]
Patch v1

This is stupid.
Comment 3 Francesco Lodolo [:flod] - OFFLINE Jun 26-Jul 3 2011-08-18 23:41:22 PDT
> This is stupid.

Care to explain?
Comment 4 Blair McBride [:Unfocused] (mostly unavailable, needinfo open, reviews not) 2011-08-19 00:35:03 PDT
(In reply to flod (Francesco Lodolo) from comment #3)
> Care to explain?

Sorry, I meant that the way labels work with wrapping is stupid. You're meant to be able to just add text as a child element to make it wrap (as opposed to using the value attribute). Which is what the code already does - so it was *meant* to wrap already :\
Comment 5 Brian King [:kinger] 2011-08-19 01:16:44 PDT
I've noticed too that wrapping does not occur without the flex, though it could depend on the container.

Why label and not description? I guess they do the same thing when used like this.
Comment 6 Blair McBride [:Unfocused] (mostly unavailable, needinfo open, reviews not) 2011-08-19 01:23:08 PDT
(In reply to Brian King (Briks) [:kinger] from comment #5)
> Why label and not description? I guess they do the same thing when used like
> this.

I considered changing it, but ultimately decided it was unnecessary code change. AFAIK there's no functional difference when using it like this - just semantic difference in the code. (Someone correct me if I'm wrong, but I don't think they're exposed differently to accessibility APIs.)
Comment 7 Dave Townsend [:mossop] 2011-08-20 11:17:35 PDT
Comment on attachment 554319 [details] [diff] [review]
Patch v1

Review of attachment 554319 [details] [diff] [review]:
-----------------------------------------------------------------

XUL!
Comment 8 Blair McBride [:Unfocused] (mostly unavailable, needinfo open, reviews not) 2011-08-21 19:38:51 PDT
http://hg.mozilla.org/integration/fx-team/rev/9d6e9b1c7807
Comment 9 Tim Taubert [:ttaubert] 2011-08-21 23:50:08 PDT
http://hg.mozilla.org/mozilla-central/rev/9d6e9b1c7807
Comment 10 Axel Hecht [:Pike] 2011-08-22 00:07:33 PDT
This looks like something we would want to take on aurora as well?
Comment 11 Blair McBride [:Unfocused] (mostly unavailable, needinfo open, reviews not) 2011-08-22 01:06:47 PDT
Comment on attachment 554319 [details] [diff] [review]
Patch v1

(In reply to Axel Hecht [:Pike] from comment #10)
> This looks like something we would want to take on aurora as well?

I think so. Minimal risk.
Comment 12 Christopher Blizzard (:blizzard) 2011-08-23 14:47:15 PDT
Comment on attachment 554319 [details] [diff] [review]
Patch v1

Approved for Aurora (Update 8.)  Please land it as soon as possible.  Thanks!
Comment 13 Blair McBride [:Unfocused] (mostly unavailable, needinfo open, reviews not) 2011-08-24 03:10:12 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/90b32d7c5cad
Comment 14 Vlad [QA] 2011-10-10 07:56:29 PDT
It's enough to update from Aurora 8.0a2 to 9.0a2 and the same thing for nightly in order to verify this? How can I verify this on beta?
Thanks
Comment 15 Dave Townsend [:mossop] 2011-10-10 10:02:17 PDT
(In reply to Vlad [QA] from comment #14)
> It's enough to update from Aurora 8.0a2 to 9.0a2 and the same thing for
> nightly in order to verify this? How can I verify this on beta?
> Thanks

Upgrading from Fireflx 7 to Firefox 8b should show the UI, doing so in an affected locale (like Italian) would probably be the best test.
Comment 16 Vlad [QA] 2011-10-12 02:55:49 PDT
I have followed the advice from comment15 in order to verify this bug.
I've upgraded from Firefox 7b6 to Firefox 8b2 and with the it locale I get a more wider window but the text in the second window (the one with two buttons: back and done) is wrapped on two lines. The same is on the en-us locale.
Is this intended?
Thanks
Comment 17 Blair McBride [:Unfocused] (mostly unavailable, needinfo open, reviews not) 2011-10-12 03:32:07 PDT
(In reply to Vlad [QA] from comment #16)
> is wrapped on two lines.

Yep, this fix was to make that wrap.
Comment 18 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2011-10-13 10:55:15 PDT
qa+ for verification in Firefox 8.
Comment 19 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2011-10-13 10:56:29 PDT
Actually, I think we can mark this verified based on comment 17 and comment 16.

Note You need to log in before you can comment on or make changes to this bug.