Closed Bug 680222 Opened 8 years ago Closed 8 years ago

Category colors are invisible - calendar-category-box width is always zero

Categories

(Calendar :: Calendar Views, defect)

x86
All
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bugzilla.i.sekler, Assigned: Paenglab)

Details

(Keywords: regression)

Attachments

(1 file)

Event boxes in Lightning have lost the display of category colors due to calendar-category-box width being always zero. All views and the Today panel are affected.

This happened at some point between <http://hg.mozilla.org/comm-central/rev/8f7fe249332e> and <http://hg.mozilla.org/comm-central/rev/f8f8c8c498b1>, possibly related to some changes in the Core, but the vast number of checkins <http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2011-08-12+06%3A47%3A00&enddate=2011-08-17+01%3A15%3A00+%2B0200> would make blind bisecting really painful.
Confirmed using Mozilla/5.0 (Windows NT 6.1; rv:8.0a2) Gecko/20110818 Thunderbird/8.0a2.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
OS: Linux → All
On Windows the regression range is different:

Works thunderbird-8.0a1.en-US.win32-2011-08-05-03-00-48-comm-central
      built from https://hg.mozilla.org/mozilla-central/rev/5684f06138f3

Fails thunderbird-8.0a1.en-US.win32-2011-08-06-03-00-31-comm-central
      built from https://hg.mozilla.org/mozilla-central/rev/ba21778fcc14

Checkins: http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2011-08-05+02:00:00&enddate=2011-08-06+04:00:00
(In reply to Stefan Sitter from comment #2)

> On Windows the regression range is different

No, the regression range I reported is just bloody wrong due to testing with patched private builds as leftovers from the investigation of the bug #678230, my apologies.

Anyway, reverting the patch <http://hg.mozilla.org/mozilla-central/rev/7fece42cb99a> from bug #585069 together with follow-up patches from bug #677091 and bug #609714 "fixes" category colors in Lightning, which apparently depends on the old behavior.
I don't know why, it's a list-style-image and not a background-image, the box has now a width of 0px. With the given width of the list-style-icon of 7px it works as before.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #554333 - Flags: review?(philipp)
Attachment #554333 - Flags: review?(philipp) → review?(bv1578)
Comment on attachment 554333 [details] [diff] [review]
Give the width of the list-style-image

I don't know why this is now necessary. I've read a bit comments on bug 609714 and something about a change in the behavior of the list-style-image is mentioned in bug 609714 comment 19, but I don't know if this issue is related.

Anyway the patch works fine on Windows, and 7 pixels is the original image's width, so it seems to me the simplest solution.

r+
Attachment #554333 - Flags: review?(bv1578) → review+
This bug was opened on TB 8.0a1. So is it okay to backport to comm-aurora?
Obviously doing something wrong, I've tried adding the (whole) patch to the C:\Users\xxxxx\AppData\Roaming\Thunderbird\Profiles\igusjd9d.Beta\extensions\{e2fda1a4-762b-4020-b5ad-a41df1933103}\chrome\calendar\skin\calendar\calendar-views.css file and also just amended the '.calendar-category-box-gradient { list-style-image: url("chrome://calendar/skin/category-overlay.png");' 
line with the addition of '+    width: 7px; }' but it makes no difference.

Anyway, if the patch is that straightforward why isn't it fixed?
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/7ec8f5088ea5>
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Backported to comm-aurora <http://hg.mozilla.org/releases/comm-aurora/rev/5ae3020b0dc4>
Target Milestone: --- → 1.0b8
Is this patch relevant for 1.0b7 too?
Not required for comm-beta.
You need to log in before you can comment on or make changes to this bug.