Closed Bug 680418 Opened 10 years ago Closed 10 years ago

Cannot start Firefox after v6 update. Crashes and won't start, even in Safe Mode.

Categories

(Firefox :: General, defect)

6 Branch
x86
Windows XP
defect
Not set
critical

Tracking

()

VERIFIED DUPLICATE of bug 670542

People

(Reporter: dnorton1, Unassigned)

Details

(Keywords: crash)

Crash Data

After updating Firefox to version 6.0.0.4240, I tried starting, and got the Mozilla Crash Reporter window. Selected "Restart", but still wouldn't start (even selected "Tell Mozilla about this crash..." and "Allow Mozilla to contact me..." check buttons.

Tried starting in Safe Mode, deselected everything, but still got the Crash Reporter window, and would not start.

Did some searching online for solutions and after looking around in support.mozilla.com, tried to create a crash report. Looking in my crash report folder, I took the most recent crash (as per this page http://support.mozilla.com/en-US/kb/Firefox%20crashes%20when%20you%20open%20it#w_getting-your-crash-report), and submitted the appropriate link (https://crash-stats.mozilla.com/report/index/7952b47a-afb6-40eb-bef5-72e162110818) hoping for a crash signature. Got "page not found" and the suggestion I enter a bugzilla report. 

Other details... Running Windows XP Pro 2000, SP3 on a Dell XPS 2.8GHz with 3.5GB RAM. 

Thanks!
David Norton
dnorton1@optonline.net
0 	xul.dll 	nsStandardURL::SchemeIs 	netwerk/base/src/nsStandardURL.cpp:1686
1 	DesktopGLSvcs.dll 	DesktopGLSvcs.dll@0x10704 	
2 	DesktopGLSvcs.dll 	DesktopGLSvcs.dll@0x8743 	
3 	xul.dll 	nsDocShell::LoadURI 	docshell/base/nsDocShell.cpp:1434
4 	xul.dll 	nsDocShell::LoadURI 	docshell/base/nsDocShell.cpp:3739
5 	xul.dll 	NS_InvokeByIndex_P 	xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp:102
6 	xul.dll 	XPC_WN_CallMethod 	js/src/xpconnect/src/xpcwrappednativejsops.cpp:1610
7 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:4685
8 	mozjs.dll 	js::RunScript 	js/src/jsinterp.cpp:613
9 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:694
10 	mozjs.dll 	js::ExternalInvoke 	js/src/jsinterp.cpp:816
11 	mozjs.dll 	JS_CallFunctionValue 	js/src/jsapi.cpp:5080
12 	xul.dll 	nsJSContext::CallEventHandler 	dom/base/nsJSEnvironment.cpp:1906
13 	xul.dll 	nsJSEventListener::HandleEvent 	dom/src/events/nsJSEventListener.cpp:224
14 	xul.dll 	nsEventListenerManager::HandleEventSubType 	content/events/src/nsEventListenerManager.cpp:1142
15 	xul.dll 	nsEventListenerManager::HandleEventInternal 	content/events/src/nsEventListenerManager.cpp:1239
16 	xul.dll 	nsEventDispatcher::Dispatch 	content/events/src/nsEventDispatcher.cpp:648
Severity: major → critical
Crash Signature: [@ nsStandardURL::SchemeIs(char const*, int*) ]
Keywords: crash
This may be a duplicate of bug 670542.

That bug says it is malware related, so you should scan your system.
Will do. I had some problems a while ago (that I ignored) and went to the Spywareinfo forums. Should have finished what I started. 

Thanks. If any further (helpful) info comes up, I'll post it.
DesktopGLSvcs.dll is the DLL that looks like malware.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 670542
Thanks for the help!

After a little bit of work, the folks at spywareinfoforums.com were able to help. (http://www.spywareinfoforum.com/index.php?/topic/132436-malware-effecting-firefox-v6-cant-start-even-in-safe-mode/)

-Dave
I want to thank you because you followed the right path to fix your problem.
Trying to fix it yourself with the support articles and then providing everything necessary in this bug report. 
A personal (!) note because I saw in your link that you had an out-of-date java version. You could try PSI (google for Personal security inspector) that keeps applications and plugins up-to-date.
Status: RESOLVED → VERIFIED
Repeat of this problem on my laptop, tried to drop back to version 5 but auto update to ver 6 screwed it again.
Still an issue going to have to use another browser....
(In reply to aranos181 from comment #10)
> Still an issue going to have to use another browser....
You have malware that makes Firefox 6 crash but no longer Firefox 7 (released on Sept 27). See the specialized forums as this malware is almost undetectable by current anti-malware software: http://support.mozilla.com/en-US/kb/Is%20my%20Firefox%20problem%20a%20result%20of%20malware
You need to log in before you can comment on or make changes to this bug.