At least in French, use the comma and not the period as decimal separator.

RESOLVED DUPLICATE of bug 368838

Status

()

RESOLVED DUPLICATE of bug 368838
7 years ago
5 years ago

People

(Reporter: nicolas.barbulesco, Unassigned)

Tracking

({l12y})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Hello,

Firefox 5.0. Mac OS X 10.6.8. French language.

See screen photo :
http://screencast.com/t/z2k5vmtzM
The Downloads window uses the period as decimal separator. This is incorrect.

Please use the comma instead, at least in French.

The comma is the standard decimal separator. It is the only one correct in French. Only English uses the period, and this is a bad idea, because the point already means multiplication in maths.

Thanks,

Nicolas

Updated

7 years ago
Component: General → Download Manager
Keywords: l12y
Product: Firefox → Toolkit
QA Contact: general → download.manager
Version: unspecified → 5 Branch

Comment 1

7 years ago
In German locale it's correct with comma, btw.
That looks like a localization bug if it works in the german locale

Comment 3

7 years ago
I'm on german win XP, if it matters, while the bug is reported on Mac

Comment 4

7 years ago
decimal symbol is deducted from Number(5.4).toLocaleString().match(/\D/).

I think (unsure) that this is computed with os locale, not firefox locale. What is your os locale. Also, what does Number(5.4).toLocaleString() returns in javascript ?
(Reporter)

Comment 5

7 years ago
Firefox 5.0 French. Mac OS X 10.6.8 set to French.

In Firefox, javascript:alert(Number(5.4).toLocaleString()); gives me 5.4.
(Reporter)

Comment 6

7 years ago
I encountered the same problem in the "About Firefox" window, during these adventures : request bug 682635. When Firefox displayed the progress of the download of the update.
(Reporter)

Comment 7

7 years ago
Firefox 6.0 Mac.
I right-click an image : Information on the image. In the size of the image, “0.47 Ko”, I get the same problem.
(Reporter)

Comment 8

5 years ago
Firefox 25.0.1, Mac OS X Mavericks.

There is the same problem in the new (crippled) Downloads window (now named Library).

There is also the problem in the Prefs → Advanced → Network.
(Reporter)

Comment 9

5 years ago
In Firefox 25.0.1 on Mavericks, the new Downloads bubble also has the problem.
(Reporter)

Comment 10

5 years ago
Let's widen the scope of this bug towards all the places where it occurs in Firefox.

In Firefox 26 Mac I encounter this bug also in the bubble that comes in when adding an extension to Firefox. 
See screen photo : 
http://pbrd.co/1aWVllG
Component: Download Manager → General
Product: Toolkit → Firefox
Version: 5 Branch → unspecified
(Reporter)

Comment 11

5 years ago
The dialog when downloading a file also has the bug. 
See screen photo : http://pbrd.co/19Vx9F9

Comment 12

5 years ago
(In reply to Nicolas Barbulesco from comment #10)
> Let's widen the scope of this bug towards all the places where it occurs in
> Firefox.
> 
> Component: Download Manager → General
> Version: 5 Branch → unspecified
> Product: Toolkit → Firefox

That's probably not helpful because Firefox/General component has little attention. (That said, I'v no better idea what to do)
it seems that this works on win32 (comment#1) and all reports are on OS X
Component: General → Widget: Cocoa
Product: Firefox → Core

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 368838
You need to log in before you can comment on or make changes to this bug.