Last Comment Bug 680827 - Undo nsPresArena workaround from bug 678422
: Undo nsPresArena workaround from bug 678422
Status: RESOLVED FIXED
[qa-]
: footprint
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla9
Assigned To: Nobody; OK to take it and work on it
:
: Jet Villegas (:jet)
Mentors:
Depends on: 678422
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-21 21:42 PDT by Nicholas Nethercote [:njn]
Modified: 2011-09-22 16:52 PDT (History)
22 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
patch (1.14 KB, patch)
2011-08-21 21:42 PDT, Nicholas Nethercote [:njn]
roc: review+
Details | Diff | Splinter Review

Description Nicholas Nethercote [:njn] 2011-08-21 21:42:28 PDT
Created attachment 554788 [details] [diff] [review]
patch

Bug 678422 worked around the ~50% wasted memory in nsPresArena caused by jemalloc rounding up PLArena's chunk requests.  Now that bug 676457 has fixed the general problem in PLArena, this workaround can be removed.
Comment 1 Nicholas Nethercote [:njn] 2011-08-21 23:35:15 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/163bc0f57747
Comment 2 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-08-22 04:46:16 PDT
http://hg.mozilla.org/mozilla-central/rev/163bc0f57747
Comment 3 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2011-09-22 16:52:28 PDT
qa- as no QA fix verification needed

Note You need to log in before you can comment on or make changes to this bug.