Account deletion doesn't work

RESOLVED FIXED

Status

--
critical
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: igarcia, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qa-])

(Reporter)

Description

7 years ago
Opening a new bug for tracking reasons.

Steps to reproduce:

1- Go to https://account.services.mozilla.com/account/delete
2- Enter Password and confirm
3- Message appear: "Oh dear.

Looks like one of the dinosaurs escaped again. We keep them away from the data, so that should be safe.

Please try again later when we've wrestled him back onto the treadmill.
"

Expected behavior on #3: Account is deleted and confirmed with an appropriate UI.

I've tested this with ibai@mozilla.com if you can track something. 

They are several users complaining in the forum too. 

The behavior is the same as these old bugs but I'm not sure if it's related: https://bugzilla.mozilla.org/show_bug.cgi?id=655282
https://bugzilla.mozilla.org/show_bug.cgi?id=673107

Thanks
Toby, ping?

Comment 2

7 years ago
i have the same problem...
Richard, are we seeing anything useful in the error logs? I don't believe we have the code pushed yet to tag an error for the user, but there should be something there if they get that message.
(Reporter)

Comment 4

7 years ago
In a side note, can we change the copy? Users get really confused with the text of the error.
(In reply to Ibai from comment #4)
> In a side note, can we change the copy? Users get really confused with the
> text of the error.

We can, but please file a separate bug for that.
(Reporter)

Comment 6

7 years ago
Any update about this?
Operations looked into this recently and determined that some DELETE calls for user data take longer than 20 seconds to complete on the database.  When this occurs, the user will see an error for their deletion request; meanwhile, some or all of their data may be deleted.

Ops and Dev are still trying to come up with a solution for the DELETE problem, which iirc is at the root of this bug as well.

Comment 8

7 years ago
Ohh,

I get the error immediately - there is no wait time.
I'm guessing it is most likely https://bugzilla.mozilla.org/show_bug.cgi?id=683395 which is awaiting train opening again to be pushed.

Comment 10

7 years ago
Unfortunately, I can still not delete my account. I do not have a registered node, and also the sync key is already destroyed.

Comment 11

7 years ago
Dear sirs,
I'm also having this issue in FF7 - however since FF5 the sync never worked well and I wanted start from scratch, however, I can still not delete my account to start over with same email adress.

Please help.
(In reply to Kris from comment #11)
> I'm also having this issue in FF7 - however since FF5 the sync never worked
> well and I wanted start from scratch, however, I can still not delete my
> account to start over with same email adress.

Kris, please file a separate bug. Here are some instructions: https://philikon.wordpress.com/2011/06/13/how-to-file-a-good-sync-bug/

Comment 13

7 years ago
I'm also seeing this issue.  I'm working on a sync client so it's critical I can reset my account (without making numerous test accounts). My sync key has been deleted, but my email address is still stored in the database so I can't create a new account with it.  Please let me know if I can be of assistance & I will provide the email address to the account in question if needed.

To cause this issue I 'cleared my sync data' first, then was still seeing errors in Firefox when trying to sync so I went ahead and tried to fully delete my account.  I got the dinosaurs error message; which I continue to get when I try and delete my account.
Will - I suspect you're running up against https://bugzilla.mozilla.org/show_bug.cgi?id=683395 which is fixed and pending a release to production. The workaround is to get yourself a sync node before deleting the account, and that should get rid of the dinosaurs.

Comment 15

7 years ago
(In reply to Toby Elliott [:telliott] from comment #14)
> The workaround is to get yourself a sync
> node before deleting the account, and that should get rid of the dinosaurs.

Thanks for the prompt reply.  This may be a dumb question, but how does one create a sync node from user land?

Comment 16

7 years ago
(In reply to Will Cosgrove from comment #15)
> 
> Thanks for the prompt reply.  This may be a dumb question, but how does one
> create a sync node from user land?

To answer my own question, it appears I have to call:
https://auth.services.mozilla.com/user/1.0/[loginname]/node/weave

Is that correct?
That's the one

Comment 18

7 years ago
I just tried calling this and I still cannot delete my account. :\
We haven't had delete failure reports recently, and I think we were having db issues during this period, so I'm closing this for now. If we get more, we can reopen.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Comment 20

7 years ago
I still can't delete my account.  id tag: 0a3589cbfa31cf93fb407ab4cf0408af.
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.