Last Comment Bug 680872 - PolyIC.cpp fails to compile on mingw-w64
: PolyIC.cpp fails to compile on mingw-w64
Status: RESOLVED FIXED
[inbound]
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: mozilla9
Assigned To: Jacek Caban
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-22 05:01 PDT by Jacek Caban
Modified: 2011-08-24 01:34 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix v1.0 (1.34 KB, patch)
2011-08-22 05:01 PDT, Jacek Caban
jorendorff: review+
Details | Diff | Splinter Review

Description Jacek Caban 2011-08-22 05:01:12 PDT
Created attachment 554827 [details] [diff] [review]
fix v1.0

That's because of Atom* to unsigned long cast that is losing precision on win64 and is an error by default on GCC. I've fixed is by using "%p" in the format and passing a pointer to JaegerSpew, so that no pointer to int conversion is needed.
Comment 1 Jason Orendorff [:jorendorff] 2011-08-22 12:12:56 PDT
Comment on attachment 554827 [details] [diff] [review]
fix v1.0

"I love you, GCC, but sometimes it seems like whatever I do, it's not good enough for you"
Comment 2 Jacek Caban 2011-08-23 08:44:17 PDT
(In reply to Jason Orendorff [:jorendorff] from comment #1)
> Comment on attachment 554827 [details] [diff] [review]
> fix v1.0
> 
> "I love you, GCC, but sometimes it seems like whatever I do, it's not good
> enough for you"

Hehe :)

http://hg.mozilla.org/integration/mozilla-inbound/rev/511103df06b4
Comment 3 Marco Bonardo [::mak] 2011-08-24 01:34:28 PDT
http://hg.mozilla.org/mozilla-central/rev/511103df06b4

Note You need to log in before you can comment on or make changes to this bug.