Content crash [@ js::RegExp::execute] on Android2.2 when loading pages

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: andreea.pod, Unassigned)

Tracking

({crash})

Trunk
ARM
Android
crash

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 554860 [details]
error

Mozilla /5.0 (Android;Linux armv7l;rv:9.0a1) Gecko/20110822 Firefox/9.0a1 Fennec/9.0a1 
Device: LG Optimus 2X (Android 2.2)

Steps to reproduce:
Open a few sites or keep going back and forward through history in a tab.

Expected results: 
Fennec should work as expected

Actual result:
an error occurs, see the screenshot.

Note:
This started happening today and it doesn't occurs following some exact steps, also it seems to happen only on Android 2.2
What is the crash report id?
https://crash-stats.mozilla.com/report/index/bp-29120996-6c02-47c2-bfac-1492d2110822
0 		@0xfffffffe 	
1 	libxul.so 	js::RegExp::execute 	js/src/jsregexpinlines.h:369
2 	libxul.so 	DoMatch 	js/src/jsstr.cpp:1476
3 	libxul.so 	js::str_replace 	js/src/jsstr.cpp:2049
4 	libxul.so 	js::InvokeKernel 	js/src/jscntxtinlines.h:286
5 	libxul.so 	js::Interpret 	js/src/jsinterp.cpp:4015
6 	libxul.so 	js::RunScript 	js/src/jsinterp.cpp:615
7 	libxul.so 	js::InvokeKernel 	js/src/vm/Stack.h:190
8 	libxul.so 	js::Invoke 	js/src/vm/Stack.h:276
9 	libxul.so 	JS_CallFunctionValue 	js/src/jsapi.cpp:5040
10 	libxul.so 	nsJSContext::CallEventHandler 	dom/base/nsJSEnvironment.cpp:1903
11 	libxul.so 	nsGlobalWindow::RunTimeout 	nsCOMPtr.h:888
12 	libxul.so 	nsGlobalWindow::TimerCallback 	nsAutoPtr.h:969
13 	libxul.so 	nsTimerImpl::Fire 	xpcom/threads/nsTimerImpl.cpp:425
14 	libxul.so 	nsTimerEvent::Run 	nsAutoPtr.h:969
15 	libxul.so 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:631
16 	libxul.so 	NS_ProcessNextEvent_P 	obj-firefox/xpcom/build/nsThreadUtils.cpp:245
17 	libxul.so 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:111
18 	libxul.so 	mozilla::ipc::MessagePumpForChildProcess::Run 	ipc/glue/MessagePump.cpp:230
19 	libxul.so 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:222
20 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:514
etc..

Naoki also filed a bug on this, bug 681069.

A crash with a similar stack was fixed by the patch in bug 596669.
Crash Signature: [@ js::RegExp::execute]
Depends on: 681069
Keywords: crash
Summary: "Sorry! Something went wrong while displaying a webpage" error when loading a page → Content crash [@ js::RegExp::execute] on Android2.2 when loading pages
tracking-firefox9: --- → ?
I wonder if it has something to do with the uncaught exception in bug 666236?
Is this still happening in current trunk build? The 2011-08-22 trunk build might have been crashy for some strange reason.
bug 666236 has been resolved, bug 680344 has been resolved.
Going to see if on monday we have any reports of this issue since the 22 build
Seems resolved.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME

Updated

7 years ago
tracking-firefox9: ? → ---
You need to log in before you can comment on or make changes to this bug.