Last Comment Bug 680917 - Assertion failure@yarr/PageAllocation.h:103 on ia64: system page size is 0x4000 while requested size is 0x1000
: Assertion failure@yarr/PageAllocation.h:103 on ia64: system page size is 0x4...
Status: RESOLVED FIXED
[inbound]
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: Other Linux
: -- normal (vote)
: mozilla10
Assigned To: Jan Horak
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-22 08:32 PDT by Jan Horak
Modified: 2011-10-05 05:13 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
ia64 assert patch 0.1 (476 bytes, patch)
2011-08-23 05:28 PDT, Jan Horak
luke: review+
Details | Diff | Splinter Review

Description Jan Horak 2011-08-22 08:32:25 PDT
On arch ia64 js engine is asserting at:
Assertion failure: isPageAligned(size)
(tip/js/src/yarr/PageAllocation.h:103 static WTF::PageAllocation WTF::PageAllocation::allocate(size_t, WTF::OSAllocator::Usage, bool, bool))

Called with following parameters:
WTF::PageAllocation::allocate (size=4096, usage=UnknownUsage, writable=true, executable=false)

From:
http://mxr.mozilla.org/mozilla-central/source/js/src/yarr/PageBlock.h#41
The isPageAligned check use systemPageSize() which returns 0x4000, size is 0x1000.

The check !(size & (pageSize() - 1)) fails because of that.
Comment 1 Mike Hommey [:glandium] 2011-08-22 08:57:53 PDT
FWIW, I think there are much more places in the code that assume a page size of 4KB.
Comment 2 Jan Horak 2011-08-23 05:28:29 PDT
Created attachment 555079 [details] [diff] [review]
ia64 assert patch 0.1

Tested attached patch with ia64 and together with patches from:
https://bugzilla.mozilla.org/show_bug.cgi?id=589735
works just fine.
Comment 3 Boris Zbarsky [:bz] (still a bit busy) 2011-09-07 08:04:49 PDT
Please put a checkin comment describing what the patch does either in the patch or in the bug?
Comment 5 Marco Bonardo [::mak] 2011-10-05 05:13:53 PDT
https://hg.mozilla.org/mozilla-central/rev/b6ae580de997

Note You need to log in before you can comment on or make changes to this bug.