Last Comment Bug 680929 - empty relations returned to atk
: empty relations returned to atk
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: Trunk
: All Linux
: -- normal (vote)
: mozilla9
Assigned To: Trevor Saunders (:tbsaunde)
:
: alexander :surkov
Mentors:
Depends on:
Blocks: 641838
  Show dependency treegraph
 
Reported: 2011-08-22 09:19 PDT by Trevor Saunders (:tbsaunde)
Modified: 2011-09-23 01:48 PDT (History)
3 users (show)
mounir: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
patch (1.12 KB, patch)
2011-08-22 09:21 PDT, Trevor Saunders (:tbsaunde)
dbolter: review+
asa: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Trevor Saunders (:tbsaunde) 2011-08-22 09:19:32 PDT
Regression from 641838, we add a relation to the set of relations in RefRelationSet() even if there is 0 targets.

This makes orca spew lots of back traces because atleast one target was expected, and otherwise makes using firefox with orca very bad.
Comment 1 Trevor Saunders (:tbsaunde) 2011-08-22 09:21:27 PDT
Created attachment 554881 [details] [diff] [review]
patch
Comment 2 David Bolter [:davidb] 2011-08-22 09:43:58 PDT
Comment on attachment 554881 [details] [diff] [review]
patch

r=me by inspection. Please test it out.
Comment 3 Trevor Saunders (:tbsaunde) 2011-08-22 10:07:54 PDT
(In reply to David Bolter [:davidb] from comment #2)
> Comment on attachment 554881 [details] [diff] [review]
> patch
> 
> r=me by inspection. Please test it out.

yeah, alreadyu did, using it now to :)
Comment 4 Trevor Saunders (:tbsaunde) 2011-08-22 11:41:27 PDT
landed http://hg.mozilla.org/integration/mozilla-inbound/rev/e11c851aab48
Comment 5 Mounir Lamouri (:mounir) 2011-08-23 01:28:52 PDT
http://hg.mozilla.org/mozilla-central/rev/e11c851aab48
Comment 6 Trevor Saunders (:tbsaunde) 2011-09-13 17:04:01 PDT
We don't have any machinary for testing the platform specific accessibility api code at the moment.  Fortunately   that code is generally a very thin wrapper.
Comment 7 Mounir Lamouri (:mounir) 2011-09-13 17:06:14 PDT
Not having the test framework isn't a reason to set in-testsuite-. Just keep the question mark.
Comment 8 Trevor Saunders (:tbsaunde) 2011-09-13 17:13:05 PDT
Comment on attachment 554881 [details] [diff] [review]
patch

This regression hsould be in aurora two since  641838 landed before  we branched but this hadn't yet.  This patch is very low risk and and only effects linux with a accessibility app running.  We've also found no regressions on trunk from it, so I doubt we'd find any before its released.  (In any cse I'm pretty sure this won't introduce any regressions.)  In theory we could fix the regrssion by backing out 641838.  However that would be a much bigger change, and would would probably involve backing out 678189 and 672515 as well.  So I think we really want to take this on aurora.

p.s. I really should have asked earlier, but I've been dealing with school
Comment 9 David Bolter [:davidb] 2011-09-22 08:04:46 PDT
Comment on attachment 554881 [details] [diff] [review]
patch

Reinstating my r+ which mysteriously evaporated.
Comment 10 Marco Zehe (:MarcoZ) 2011-09-23 01:48:59 PDT
Landed on tbsaunde's behalf: http://hg.mozilla.org/releases/mozilla-aurora/rev/2ef302863818

Note You need to log in before you can comment on or make changes to this bug.