Can't select category in searchpanel sidebar

VERIFIED DUPLICATE of bug 67944

Status

VERIFIED DUPLICATE of bug 67944
18 years ago
11 years ago

People

(Reporter: morse, Assigned: hyatt)

Tracking

({regression})

Trunk
x86
Windows NT
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
1. Start with fresh profile
2. From menu do search->my-sidebar->advanced
3. In sidebar panel click on pop-up list

Nothing happens.

Expected list to open so that a selection could be made

Each time the list is clicked on, the following appears on the console:

JavaScript error:
 line 0: uncaught exception: [Exception... "Component returned failure code: 0x8
0004005 (NS_ERROR_FAILURE) [nsIMenuBoxObject.activeChild]"  nsresult: "0x8000400
5 (NS_ERROR_FAILURE)"  location: "JS frame :: <unknown filename> :: onxblcreate
:: line 5"  data: no]

This is a recent regression.

Comment 1

18 years ago
Win2K with 2/08 build, and clicking on Advanced does what it seems to do.
(Reporter)

Comment 2

18 years ago
Forgot to mention -- I observed this on a winnt build that I pulled and built on 
2-7.  Also on a linux build that I pulled and built this morning (2-8).

Comment 3

18 years ago
Looked into this.  Seems that the list is gererated from rdf 
ref="NC:SearchCategoryRoot"  ..... 
last week a check in went into the back end that broke it but not sure
what the check in was.   The panel's frontend has not been changed for awhile.
giving to hyatt for help
http://lxr.mozilla.org/seamonkey/source/xpfe/components/search/resources/search-
panel.xul#66
Assignee: matt → hyatt
Keywords: nsbeta1, regression

*** This bug has been marked as a duplicate of 67944 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 5

18 years ago
VERIFIED Dupe
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.