The default bug view has changed. See this FAQ.

checkbox input does not enable after reload

RESOLVED DUPLICATE of bug 654072

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 654072
6 years ago
4 years ago

People

(Reporter: Thomas, Unassigned)

Tracking

7 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:7.0) Gecko/20100101 Firefox/7.0
Build ID: 20110816154714

Steps to reproduce:

I have disabled a checkbox using Javascript and reloaded the page.


Actual results:

The checkbox remained disabled.


Expected results:

The checkbox should not be disabled since there is nothing (js, html etc) disabling the checkbox.
Testcase?

Does a Nightly Build show the same Issue?
http://nightly.mozilla.org/
(Reporter)

Comment 2

6 years ago
Testcase:

<html>
<body>
<script>
document.getElementsByTagName('body')[0].onclick = function() {
	document.getElementsByTagName('input')[0].disabled = true;
}
</script>
<input type="checkbox">
</body>
</html>

Upon refresh after clicking on the body the checkbox does not re-enable. Testcase in other browsers works as expected.
Created attachment 555560 [details]
Reporter's Testcase

Ok, to get it right:

* load the Testcase

What should be expected: Checkbox disabled or enabled State?

* clicking on the Body

disabled or enabled?

* reloading (normal)

disabled or enabled?

* reloading (bypassing the Cache using e.g. CTRL+F5)

disabled or enabled?

Whatever the expected Result is, I see differences amongst Firefox Nightly, Opera Next and Chrome 15 in some Steps.

Maybe it's too late over here that I fail to understand properly :-)
(Reporter)

Comment 4

6 years ago
What I get when I load this Testcase in the most recent FF 7

* load the Testcase

checkbox enabled

* clicking on the Body (body is quite small so click next to the checkbox)

checkbox disabled

* reloading (normal)

expected: checkbox enabled
actual: checkbox still disabled

* reloading (bypassing the Cache using e.g. CTRL+F5)

expected: checkbox enabled
actual: checkbox still disabled

So the enabled/disabled state is not restored upon refresh.

Comment 5

6 years ago
Still disabled after F5, but enabled after Ctrl+F5:
Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.2.20) Gecko/20110803 Firefox/3.6.20
Mozilla/5.0 (X11; Linux x86_64; rv:6.0) Gecko/20100101 Firefox/6.0
Mozilla/5.0 (X11; Linux x86_64; rv:7.0) Gecko/20100101 Firefox/7.0
Mozilla/5.0 (X11; Linux x86_64; rv:8.0a2) Gecko/20110825 Firefox/8.0a2
Mozilla/5.0 (X11; Linux x86_64; rv:9.0a1) Gecko/20110825 Firefox/9.0a1
looks like a dupe of bug 654072
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 654072
You need to log in before you can comment on or make changes to this bug.