Last Comment Bug 6814 - UTF-7 IMAP4rev1 modified version page is not displayed correctly
: UTF-7 IMAP4rev1 modified version page is not displayed correctly
Status: VERIFIED FIXED
:
Product: Core
Classification: Components
Component: Internationalization (show other bugs)
: Trunk
: All Windows NT
: P2 major (vote)
: M7
Assigned To: cata
: Katsuhiko Momoi
Mentors:
http://babel/tests/browser/charset/ut...
Depends on: 6813
Blocks: 7130
  Show dependency treegraph
 
Reported: 1999-05-20 12:13 PDT by Teruko Kobayashi
Modified: 1999-06-16 01:19 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Teruko Kobayashi 1999-05-20 12:13:34 PDT
Tested 5-20 Win32 and Mac build.

This page has meta charset.  UTF-7 IMAP4rev1 modified version character is not displayed correctly.
Comment 1 Katsuhiko Momoi 1999-05-26 17:07:59 PDT
Practical testing for this should be done on IMAP servers
many different charactesr since we are not likely encounter real
web pages written in this charset.
(Or at least mail testers need to be aware of the problems.)
Pass this on to me when the converter has been proven to be
there.
Comment 2 Katsuhiko Momoi 1999-06-11 16:28:59 PDT
There is one browser test available now, which we know to be a
correct modified UTF-7 string quoted from RFC 2060. See the
above URL. (Until we have the IMAP folder name working (Bug 7130),
we can't look at real IMAP folder name examples.)

This string contains ASCII, Japanese, and Chinese data.
The Chinese data do not display correctly. (Japanese data do.)
Comment 3 Katsuhiko Momoi 1999-06-11 18:24:59 PDT
The correct test string from RFC 2060 is:

~peter/mail/&ZeVnLIqe-/&U,BTFw-

Note the modified UTF-7 "," instead of "/" as used in UTF-7.

If you change "," back to "/", you can see the Chinese
word "Taipei" under the encoding for modified UTF-7 for IMAP4.

~peter/mail/&ZeVnLIqe-/&U/BTFw-

I have a sample of this in text format:

http://rocknroll/users/momoi/publish/seamonkey/tests/simplemodutf7.txt

The original in text format is here:

http://rocknroll/users/momoi/publish/seamonkey/tests/simplemodutf7orig.txt
Comment 4 cata 1999-06-14 14:42:59 PDT
Should be fixed now. (It was a typo: "/" was accepted instead ",")
Comment 5 Katsuhiko Momoi 1999-06-16 01:19:59 PDT
** Checked with 6/15/9 Win32 build **

The above URL now displays correctly (ASCII, Japanese, Chinese)
with this new build.

It also displays a longer test page such as follows correctly:

http://rocknroll/users/momoi/publish/seamonkey/tests/modutf7correct_test.html

Marking it verified/fixed.

Note You need to log in before you can comment on or make changes to this bug.