Closed Bug 681421 Opened 9 years ago Closed 8 years ago

Typing doesn't work on touch.facebook.com

Categories

(Firefox for Android Graveyard :: General, defect)

defect
Not set

Tracking

(firefox8+, firefox9+)

RESOLVED WORKSFORME
Tracking Status
firefox8 + ---
firefox9 + ---

People

(Reporter: ehsan, Assigned: mbrubeck)

References

Details

(Keywords: regression, testcase, Whiteboard: [website-compatibility], [short-list])

Attachments

(2 files)

STR:

1. Go to http://touch.facebook.com
2. Focus the status text box, and try to type something.

I've seen this on my Galaxy S Vibrant and also Galaxy Tab 10.1.
Attached file testcase
You can focus and type at touch.facebook.com, it just doesn't show up or much later than you would expect (after switching tabs or so).
OS: Mac OS X → All
Hardware: x86 → All
Regressed between 2011-05-01 and 2011-05-02, using the testcase and Fennec builds on Windows:
http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2011-05-01+02%3A00%3A00&enddate=2011-05-02+09%3A00%3A00
Regression from bug 653780?
Hmm, it seem to me a regression from bug 640048. This looks like a layers bug to me.
Blocks: 640048
Attached file testcase2
Whiteboard: [website-compatibility]
Benjamin, could you take a look please?
I don't think I can look at this any time soon. Maybe Wes or Matt?

As a general outline, check out this bug:
https://bugzilla.mozilla.org/show_bug.cgi?id=683206

Ideally we need to be watching any element we set the displayport on. If it scrolls on its own we could end up in a situation where its text doesn't update. We could try removing the display port on the element whenever a user starts typing, as a stop gap measure.
Verified in Mozilla/5.0 (Android; Linux armv7l; rv:9.0a 1)Gecko/20110909 Firefox/9.0a1 Fennec/9.0a1
The typing shows long after the expected or after tapping the field.
This didn't happen in the builds earlier than September 6.
I forgot to add the above was checked in a Samsung Galaxy Tab 10.1
It seems it's fixed in:
Mozilla/5.0 (Android; Linux armv7l; rv:9.0a 1)Gecko/20110929 Firefox/9.0a1 Fennec/9.0a1
OS: Android
Device: Samsung Galaxy Tab 10.1

The typing shows immediately as it should.
Assignee: nobody → mbrubeck
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
The first testcase still shows the typing problem mentioned in comment 2.
At least nice that the problem isn't there anymore on facebook, at least.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
I still see this when trying to type a friends name to search for them.  Facebook Menu button -> Friends -> try to type a name.
Whiteboard: [website-compatibility] → [website-compatibility][short-list]
Whiteboard: [website-compatibility][short-list] → [website-compatibility], [short-list]
Please re-test. This WFM on recent builds.
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.