In nsMsgFilterCore.idl : const long News=0xb; is wrong.

RESOLVED FIXED

Status

MailNews Core
Search
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Jesse Weinstein, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.18) Gecko/20110628 Ubuntu/10.04 (lucid) Firefox/3.6.18
Build ID: 20110628230241

Steps to reproduce:

I was looking through the code for Thunderbird's message filters, specifically trying to understand what the "type" attribute was used for.


Actual results:

In mailnews/base/search/public/nsMsgFilterCore.idl the type attribute is defined by the nsMsgFilterType interface.  It appears to be a bitfield of length 4, with the low two bits referring to Inbox filters and the high bits referring to News filters.  Within each nibble, the low one is Rules and the high one is JavaScript.  The interface also declares some shorthand names for multiple types; specifically, Inbox, News, and All.  Inbox is (correctly) set to 0x3 (the lower nibble), and All to 0xf (all 4 bits), but News is set to 0xb, rather than 0xc (the upper nibble).


Expected results:

This hasn't been noticed because the News shorthand doesn't seem to have ever been used; and nothing has been changed in the values since 1999.

Updated

6 years ago
Component: Search → Search
Product: SeaMonkey → MailNews Core
QA Contact: search → search

Comment 1

6 years ago
Erm, where did you look?!
This was already fixed three years ago in bug 440635 (http://hg.mozilla.org/comm-central/rev/0b9574280e22)...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

6 years ago
I looked in MXR, on the seamonkey tree, here: https://mxr.mozilla.org/seamonkey/source/mailnews/base/search/public/nsMsgFilterCore.idl#52  It's certainly odd (and kinda alarming) that what shows up there is apparently 3 years out of date!  Sorry for the bugspam.
(In reply to Jesse Weinstein from comment #2)
> I looked in MXR, on the seamonkey tree, here:
> https://mxr.mozilla.org/seamonkey/source/mailnews/base/search/public/
> nsMsgFilterCore.idl#52  It's certainly odd (and kinda alarming) that what
> shows up there is apparently 3 years out of date!  Sorry for the bugspam.

That tree is for the old CVS source, see the description at https://mxr.mozilla.org: "This the old code in CVS for Gecko, XULRunner, Firefox, Thunderbird, Calendar, Camino, and SeaMonkey. For Gecko, XULRunner, and Firefox. CVS trunk is only used for Gecko 1.9.0 / Firefox 3 and the 1.9.0.* / 3.0.* security releases. "

What you want is https://mxr.mozilla.org/comm-central/
You need to log in before you can comment on or make changes to this bug.