If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Error: Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIDOMWindow.alert] after checked checkbox of "Prevent this page from creating additional dialogs". And Browser would not execute Javascript Codes which placed after the alert()

RESOLVED DUPLICATE of bug 633154

Status

()

Core
DOM: Core & HTML
RESOLVED DUPLICATE of bug 633154
6 years ago
6 years ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [good first bug] [mentor=jdm])

Attachments

(1 attachment, 1 obsolete attachment)

485 bytes, text/html
Details
(Reporter)

Description

6 years ago
Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/7eb1a56eaaf1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0a1) Gecko/20110823 Firefox/9.0a1 ID:20110823030804

Reproducible: Always

Steps to Reproduce:
1. Open Firefox with clean profile
2. Open Error Console
3. Open testcase
4. Click a button

5. When an alert box appeares,
5-1. If there is no checkbox of "Prevent this page from creating additional" dialogs, just click "OK" button.
5-2. If there is a checkbox of "Prevent this page from creating additional" dialogs, check the checkbox and click "OK" button.

5. Repeat Step 4 and 5(5-1/5-2) til an error massage appears in the Error Console

Actual Results:
  An error massage appears as follow.
  Error: Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIDOMWindow.alert]

  Browser would not execute Javascript Codes which placed after the alert() statement;


Expected Results:
  No error.
  Browser should execute Javascript Codes which placed after the alert() statement silently;
(Reporter)

Comment 1

6 years ago
Created attachment 555238 [details]
testcase
(Reporter)

Updated

6 years ago
OS: Windows XP → All
Hardware: x86 → All
Summary: Error: Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIDOMWindow.alert] after checked checkbox of "Prevent this page from creating additional dialogs". → Error: Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIDOMWindow.alert] after checked checkbox of "Prevent this page from creating additional dialogs". And Browser would not execute Javascript Codes which placed after the alert()
(Reporter)

Comment 2

6 years ago
Created attachment 555241 [details]
testcase
Attachment #555238 - Attachment is obsolete: true

Comment 3

6 years ago
This should just be an easy change from |return NS_ERROR_NOT_AVAILABLE| to |return NS_OK| in nsGlobalWindow::Alert, nsGlobalWindow::Prompt, and nsGlobalWindow::Confirm.
Whiteboard: [good first bug] [mentor=jdm]
(Reporter)

Updated

6 years ago
Blocks: 61098
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 633154
You need to log in before you can comment on or make changes to this bug.