SVG size wrong when based on width/height percentage

RESOLVED DUPLICATE of bug 668163

Status

()

RESOLVED DUPLICATE of bug 668163
8 years ago
8 years ago

People

(Reporter: galmok, Unassigned)

Tracking

9 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:9.0a1) Gecko/20110820 Firefox/9.0a1
Build ID: 20110820030758

Steps to reproduce:

I visit Garmin Connect which draws an SVG route upon a map (link to exampled below). 

http://connect.garmin.com/activity/108993784

Only the upper left of the route is shown. 


Actual results:

The SVG code seems to be inserted dynamically depending on map zoom/pan but the svg is created with width and height set to 100% which produces a too small area for the path to be shown in. 

Using the builtin Webdeveloper/Inspect tool, the SVG tag and its parent tags are easily found. Changing width/height of the SVG element from "100%" to the size of the parent makes the whole route visible.


Expected results:

The SVG route should have been displayed without arbitrary clipping.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 668163
You need to log in before you can comment on or make changes to this bug.