The default bug view has changed. See this FAQ.

Panning breaks when element is made visible (m.xkcd.com)

VERIFIED FIXED in Firefox 7

Status

Fennec Graveyard
Panning/Zooming
P3
normal
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: CoJaBo, Assigned: mbrubeck)

Tracking

({regression, verified-aurora, verified-beta})

Firefox 7
Firefox 7
All
Android
regression, verified-aurora, verified-beta

Details

(Whiteboard: [qa-])

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

6 years ago
Created attachment 555372 [details]
Bug in landscape mode.

Tested on nightly 2011-08-24 using Droid X, screen resolution 480×854.
This has happened sporadically since at least 7.0a and on other sites, but it took a while to locate a reproducible case.

1. Go to http://m.xkcd.com/583/ (if in landscape mode),
or go to http://m.xkcd.com/882/ (if in portrait mode)
(The bug does not present when either URL is loaded in the opposite orientation. It will also present on some, but not all, other comics.)
2. Zoom in all the way and pan to the top-right corner.
3. Tap on the image. (This toggles the element altText at the bottom of the page from display:none to display:block)
4. Zoom out.

Actual:
When the image is tapped, the page jerks to the side.
When zoomed out, the left margin of the page falls somewhere in the middle of the screen, and the remaining left side of the screen is checkerboarded.
Note the position of the altText element, centered at the bottom in the visible fragment of the page.
Attempting to zoom or pan causes the page to jerk around erratically, which sometimes persists when reloaded (closing the tab and reopening the page is necessary to reset).

Expected:
The page should not move when tapped and should display as normal when zoomed out.
Created attachment 556577 [details]
bug in portrait mode

Confirmed, I can reproduce it with the steps to reproduce.

Updated

6 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
(Assignee)

Comment 2

6 years ago
I can look into this.  (Assigning as a reminder to myself, but if someone else wants to steal this, feel free.)
Assignee: nobody → mbrubeck
tracking-fennec: --- → ?
(Assignee)

Comment 3

6 years ago
When this bug happens, we are getting a MozScrolledAreaChanged event in the content process with aEvent.x < 0, (for example, I just got one with aEvent.x == -322).
(Assignee)

Comment 4

6 years ago
Created attachment 557937 [details] [diff] [review]
WIP

This patch fixes the bug, but I need to check whether it is correct or if it cause any other regressions.
(Assignee)

Updated

6 years ago
Blocks: 634386
(Assignee)

Comment 5

6 years ago
Created attachment 557961 [details] [diff] [review]
patch

This fixes the bug.  When the page is scrolled to the right, the MozScrolledAreaEvent ".x" property has to be adjusted by the scroll position.  I verified this does not the test cases in bug 634386 for which this code was added.  (My previous patch where I just changed the value to zero *did* regress those test cases.)
Attachment #557937 - Attachment is obsolete: true
Attachment #557961 - Flags: review?(ben)
Attachment #557961 - Flags: review?(ben) → review+
(Assignee)

Comment 6

6 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/fc2a18413a7e
Status: NEW → ASSIGNED
Keywords: regression
Whiteboard: [inbound]
(Assignee)

Comment 7

6 years ago
Comment on attachment 557961 [details] [diff] [review]
patch

After this has been on Nightly a few days, I'd like approval to land it on Aurora and Beta.  It's a very low risk mobile-only fix for a regression in Firefox 7.  The regression causes broken panning and/or checkerboards that don't go away.  It can be triggered by content JavaScript, or by double-tap with "reformat on zoom" enabled.

P.S. Big thanks to CoJaBo for finding steps to reproduce this bug!
Attachment #557961 - Flags: approval-mozilla-beta?
Attachment #557961 - Flags: approval-mozilla-aurora?
http://hg.mozilla.org/mozilla-central/rev/fc2a18413a7e
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Whiteboard: [inbound]
Target Milestone: --- → Firefox 9

Updated

6 years ago
tracking-fennec: ? → ---

Updated

6 years ago
tracking-firefox7: --- → +

Comment 9

6 years ago
Comment on attachment 557961 [details] [diff] [review]
patch

Approved for mozilla-aurora and mozilla-beta. Please land asap!
Attachment #557961 - Flags: approval-mozilla-beta?
Attachment #557961 - Flags: approval-mozilla-beta+
Attachment #557961 - Flags: approval-mozilla-aurora?
Attachment #557961 - Flags: approval-mozilla-aurora+
(Assignee)

Comment 10

6 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/8fcbe854cf76
https://hg.mozilla.org/releases/mozilla-beta/rev/6fea04ad4a75
status-firefox6: --- → unaffected
status-firefox7: --- → fixed
status-firefox8: --- → fixed
Target Milestone: Firefox 9 → Firefox 7
Version: Trunk → Firefox 7
I cannot reproduce this issue anymore on the latest Firefox 7 Beta build, performing the steps from comment #0. I'll mark this bug as verified fixed.

--
Mozilla/5.0 (Android;Linux armv7l;rv:7.0)Gecko/20110908
Firefox/7.0 Fennec/7.0
Device: Motorola Droid 2
OS: Android 2.3
Status: RESOLVED → VERIFIED
v.

Mozilla/5.0 (Android;Linux armv7l;rv:8.0a2)Gecko/20110909
Firefox/8.0a2 Fennec/8.0a2

Mozilla/5.0 (Android;Linux armv7l;rv:9.0a1)Gecko/20110909
Firefox/9.0a1 Fennec/9.0a1
Keywords: verified-aurora, verified-beta
Mozilla/5.0 (Android; Linux armv7l; rv:9.0a 1)Gecko/20110909 Firefox/9.0a1 Fennec/9.0a1

Works fine for me in a Samsung Galaxy Tab 10.1
QA no longer needs to track this, since it's been verified across the board.
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.