Does not work on PPC Mac mini as advertised

RESOLVED FIXED

Status

Release Engineering
General
RESOLVED FIXED
7 years ago
5 years ago

People

(Reporter: donbaker893, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.2.17) Gecko/20110420 Firefox/3.6.17
Build ID: 20110420140830

Steps to reproduce:

Tried to update from 3.6.17 to 3.6.20 on Mac Mini PPC OS X 10.4.11


Actual results:

Your web site says that 3.6.20 is compatible with my system at
https://www.mozilla.com/en-US/firefox/3.6.20/system-requirements/
But when I downloaded and tried to install it, it shows up with a crossout mark on top of the logo in the DMG folder, and claims that it does not support my architecture when I try to run it.  Then when I tried to file feedback about it at
http://input.mozilla.com/en-US/download
you so kindly informed me that I can't without the "latest version".

Lovely.


Expected results:

Either your stated system requirements should be accurate, or if you no longer support a system, you should clearly show which version was the last and best that will work on it.  When someone does "Check for updates" you should not suck anyone in with a claim that they need to update to the latest version, when you no longer support their system.  Just do some checking and state outright that the system is no longer supported.
3.6.x should work on PPC, moving to release engendering
Component: Installer → Release Engineering
Product: Firefox → mozilla.org
QA Contact: installer → release
Version: 3.6 Branch → other
Don, could you confirm the filename of the dmg includes 3.6.20, just to rule out getting 6.0 by accident.

I can't reproduce the problem with en-US 3.6.20 on a PPC machine we have (bm-xserve04)
Also, looking at http://tinderbox.mozilla.org/showbuilds.cgi?tree=GeriatricMachines suggests that at minimum, mozilla-central builds are able to start on PPC and run through unit tests.
(In reply to John Ford [:jhford] from comment #3)
> Also, looking at
> http://tinderbox.mozilla.org/showbuilds.cgi?tree=GeriatricMachines suggests
> that at minimum, mozilla-central builds are able to start on PPC and run
> through unit tests.

Apologies, that should read mozilla-1.9.2, which is the Firefox 3.6 tree.
(Reporter)

Comment 5

7 years ago
I think I see what happened.  It depends on which link you click on in the Update box.  If I remember correctly, I clicked on the one that set my to the Firefox web site, so that I could be sure that it works with my "obsolete" computer.  But the web site sent me to Version 6, with no way I could see to get to 3.6.20.  So that's what I downloaded, thinking that the ".6." meant ver 6.  I don't keep up with these things, since I can't afford new software or equipment.  I've already trashed and emptied the .dmg file, but the "get info" on the non-working app identifies it as version 6.  I just did the manual update again without going to the web site.  Restarting Firefox now shows version 3.6.20, which seems to work.  

If I may suggest, your web site could use a few more explicit choices to allow us to get to the right archived or updated version.  Thank you.
(Reporter)

Comment 6

7 years ago
"that sent me" not "that set my"

Comment 7

7 years ago
(In reply to donbaker893 from comment #5)
> Restarting
> Firefox now shows version 3.6.20, which seems to work.  
> 
> If I may suggest, your web site could use a few more explicit choices to
> allow us to get to the right archived or updated version.  Thank you.

Glad you got it working. Sorry for the trouble.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.