CRT ASSERT strftime.c(833) : Assertion failed: ( "Invalid format directive" , 0 ) in js1_5/extensions/toLocaleFormat-02.js

RESOLVED DUPLICATE of bug 818634

Status

()

defect
RESOLVED DUPLICATE of bug 818634
8 years ago
2 years ago

People

(Reporter: bc, Unassigned)

Tracking

({assertion})

Trunk
x86
Windows XP
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [leave open][test disabled] js-triage-needed)

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
1. apply patch in https://bugzilla.mozilla.org/show_bug.cgi?id=587982
2. run js1_5/extensions/toLocaleFormat-02.js in the browser

js1_5/extensions/toLocaleFormat-02.js on WinXP fails with 

ABORT: CRT ASSERT strftime.c(833) : Assertion failed: ( "Invalid format directive" , 0 )

Win7 also fails but it is missing the ABORT message in the log at the moment.

http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/bclary@mozilla.com-0b488974dd3f/try-win32-debug/try_xp-debug_test-jsreftest-build532.txt.gz

http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/bclary@mozilla.com-0b488974dd3f/try-win32-debug/try_win7-debug_test-jsreftest-build650.txt.gz

Question: In bug 587982, I made CRT assertions as well as CRT errors fatal. Is that appropriate or should it have been non-fatal?
Flags: in-testsuite+
Whiteboard: js-triage-needed
(Reporter)

Comment 1

7 years ago
This blocks adding CRT Debug aborts in bug 587982. I ran jstestbrowser with this test disabled and passed.
Attachment #647169 - Flags: review?(dmandelin)
Attachment #647169 - Flags: review?(dmandelin) → review+
(Reporter)

Comment 2

7 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/7ca10f967b05

Do not mark this fixed when this lands on mozilla-central. The underlying bug is still there.
Whiteboard: js-triage-needed → [leave open] js-triage-needed
https://hg.mozilla.org/mozilla-central/rev/7ca10f967b05
Whiteboard: [leave open] js-triage-needed → [leave open][test disabled] js-triage-needed
I just got one of these while debugging metrofx. bing.com was the page loaded. the browser was sitting for a bit without interaction and then it crashed. Will attach a stack.
Posted file crash stack
f:\dd\vctools\crt_bld\self_x86\crt\src\strftime.c(798) : Assertion failed: ( "Invalid format directive" , 0 )

strftime params:

buf: 0x03386eac "Sun Iø\ti\x6"
buflen: 100
fmt: 0x0b9d3fa0 "%a %R"
The observer event was "weave:service:login:finish"

Updated

6 years ago
Depends on: 794927
Assignee: general → nobody
toLocaleFormat was removed in bug 818634.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 818634
You need to log in before you can comment on or make changes to this bug.