Closed Bug 681879 Opened 9 years ago Closed 9 years ago

The "Delete Button" "(X)" from the 'location history autocomplete' is missing

Categories

(Firefox :: Address Bar, defect)

9 Branch
x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 675818

People

(Reporter: rob1weld, Unassigned)

Details

- Click on URL Location Bar and start typing (anything or) a prior URL.
- As you type previous URLs visited (containing the text typed) will show up.

- If you wish to delete some of the superfluous Junk I _thought_ we USED TO be able to move the Mouse over to the right side of the Pulldown and a dark grey "(X)" would appear; clicking on that would delete the Entry and clean up the List. Now that dark grey "(X)" is missing.


I remember we had this feature a few weeks ago (didn't we).

Why remove it (as it only showed upon mouseover) - alternately this is a RFE and not an Bug; as the feature was removed on purpose and I am requesting its return.

This Bug affects ones ability to type with one hand and simultaneously mouse with the other. Touch-typing with two hands is fine for (extended) periods of typing BUT for us 'power surfers' it is mousing with one hand and typing with the other (for some / most? people).

Switching from 'two-hand to one hand', 'pulling off the mouse' or 'crossing the board' defeats the speed of "one-handed touch-typing".


I hope no one feels I am making a mountain out of a molehill - if the effort to break the Code or the deliberate removal of the feature had not occurred I would not be requesting it's return. This may be part of a bigger Bug, see end of this comment, so a fine eye for the details can be helpful lest we suffer an erosion of our favorite features... (Yowl, foot breaks through thin soapbox board; trapping foot - shakes leg in vain attempt to free oneself).



BTW: Upon search (for Dupes prior to this posting) I discovered we could take our hand off the Mouse and hit the [Delete] Key to perform the same function that clicking on the "(X)" would have done.


This is very loosely related (yet seems fixed in Nightly, and still open): Bug 636992
(In reply to Rob from comment #0)

> - If you wish to delete some of the superfluous Junk I _thought_ we USED TO
> be able to move the Mouse over to the right side of the Pulldown and a dark
> grey "(X)" would appear; clicking on that would delete the Entry and clean
> up the List. Now that dark grey "(X)" is missing.
> 
> 
> I remember we had this feature a few weeks ago (didn't we).

We never had such a button, we plan to add it.  You probably had some addon or were testing UX branch.
So this is actually invalid, but since it's asking for the delete button, I'm duping to the bug implementing it.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 675818
(In reply to Marco Bonardo [:mak] from comment #1)
> (In reply to Rob from comment #0)
> 
> > - If you wish to delete some of the superfluous Junk I _thought_ we USED TO
> > be able to move the Mouse over to the right side of the Pulldown and a dark
> > grey "(X)" would appear; clicking on that would delete the Entry and clean
> > up the List. Now that dark grey "(X)" is missing.
> > 
> > 
> > I remember we had this feature a few weeks ago (didn't we).
> 
> We never had such a button, we plan to add it.  You probably had some addon
> or were testing UX branch.
> So this is actually invalid, but since it's asking for the delete button,
> I'm duping to the bug implementing it.
> 
> *** This bug has been marked as a duplicate of bug 675818 ***

Maybe I am clairvoyant ...

I have Nightly, Aurora and now FF6 (was 5 yesterday).

If I can find which add-on I had (that added that Button) I'll post in Bug 675818, for references purposes.

Thanks for duping to the RFE, good job Marco.


YT,
Rob
You need to log in before you can comment on or make changes to this bug.