Document.bgColor property isn't functioning in XHTML

VERIFIED DUPLICATE of bug 111514

Status

()

Core
XML
P3
normal
VERIFIED DUPLICATE of bug 111514
18 years ago
16 years ago

People

(Reporter: Chris Petersen, Assigned: Heikki Toivonen (remove -bugzilla when emailing directly))

Tracking

({xhtml})

Trunk
Future
xhtml
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Build: 2001020804
Platform: All
Expected results: Modifing document.bgColor property should function.
What I got: This property is not working.

Steps to reproduce:

1) Open test case

2) Clicking on any of the buttons should change the document's background color.

3) Background color is not changed.
(Reporter)

Comment 1

18 years ago
Adding xhtml keyword
Keywords: xhtml
(Reporter)

Comment 2

18 years ago
Nominating for nsbeta1. Document properties such as bgcolor should function in 
XHTML.
Keywords: nsbeta1
I disagree, changing document's background color via script isn't a beta
stopper. You can set the backround color with CSS and attributes on the body
element.

This bug has been marked "future" because the original netscape engineer
working on this is over-burdened. If you feel this is an error, that you or
another known resource will be working on this bug,or if it blocks your work
in some way -- please attach your concern to the bug for reconsideration.
Keywords: nsbeta1 → nsbeta1-
Target Milestone: --- → Future

Comment 4

17 years ago
Actually setting the bgcolor in a normal html doesn't seem to work either..
http://gemal.dk/util/bgcolor.html

Comment 5

17 years ago
This doesn't seem like an XML or XHTML bug to me.  I doesn't work in normal HTML
documents either.  I think it ought to be re-categorized as a DOM0 bug.

And it ought to be fixed.  This bug breaks any web site that does cheesy
background color animations (fade to black...)

And, for what its worth, it breaks an example in my book JavaScript:The
Definitive Guide.  There are hundreds of thousands of javascripters out there
who may try to run the example with Mozilla!
(Reporter)

Comment 6

17 years ago
This works in a HTML Transitional 4.0 document:

http://mozilla.org/quality/browser/standards/html/script_src.html 
(Reporter)

Comment 7

17 years ago
David, 

You might try pulling a newer build since it works for me with HTML files (June
28th). This may have accidentally got broken then got fixed. This particular bug
is a XHTML issue only.
Priority: -- → P3
Target Milestone: Future → mozilla0.9.8
Target Milestone: mozilla0.9.8 → mozilla0.9.9
Target Milestone: mozilla0.9.9 → Future
XHTML as xml gets an XML document instead of an HTML one, hence no bgcolor property.

*** This bug has been marked as a duplicate of 111514 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 9

16 years ago
Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.